New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot find modules errors when starting passport #43

Closed
jgomer2001 opened this Issue Aug 23, 2018 · 4 comments

Comments

Projects
None yet
2 participants
@jgomer2001
Contributor

jgomer2001 commented Aug 23, 2018

Doing QA for 3.1.4 team members have found errors of this nature when starting passport

Error: Cannot find module 'passport-dropbox-oauth2'

Sometimes with other modules like passport-openidconnect, express, winston-daily-rotate-file, dateformat.

They resorted to using npm install <package-name> –save

@jgomer2001 jgomer2001 added this to the 3.1.4 milestone Aug 23, 2018

@jgomer2001 jgomer2001 self-assigned this Aug 23, 2018

@jgomer2001

This comment has been minimized.

Contributor

jgomer2001 commented Aug 24, 2018

This is due to wrong file /opt/dist/gluu/passport-node_modules.tar.gz in binary packages

@syntrydy

This comment has been minimized.

Contributor

syntrydy commented Aug 24, 2018

@jgomer2001 so the packaging team should fix?

@jgomer2001

This comment has been minimized.

Contributor

jgomer2001 commented Aug 24, 2018

@syntrydy they should not include that file until this issue is closed. By default, if the file is missing, the installer does the standard npm installation that requires internet connectivity

@jgomer2001

This comment has been minimized.

Contributor

jgomer2001 commented Aug 31, 2018

the .tar.gz looks proper now. I'll reopen if there are problems in QA for release candidate packages. Latest feedback has been positive

@jgomer2001 jgomer2001 closed this Aug 31, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment