New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OTP doesn't work in centos6 #907

Closed
natt-tester opened this Issue Sep 21, 2018 · 3 comments

Comments

Projects
None yet
4 participants
@natt-tester

natt-tester commented Sep 21, 2018

Preconditions: At least 1 user and one admin account created.

Steps:

  1. Follow the docs and set up OTP as your default auth in a fresh VM with centos6 (RC6, Firefox)
  2. Scan the QR and enter the code as admin
  3. Log in to oxtrust
  4. Wait for several minutes (10-15)
  5. Change the password of the user
  6. Log out
  7. Try to log in again

Neither user can log in again. The message always says the following:
centos6_rc6final_otp

2018_09_21.jetty.log.tar.gz
oxauth_logs.tar.gz
oxtrust_logs.tar.gz

@natt-tester natt-tester added this to the 3.1.4 milestone Sep 21, 2018

@yurem

This comment has been minimized.

Contributor

yurem commented Sep 24, 2018

It’s time based authentication method. Hence time on server and your mobile phone should be in sync.
Can you check if the time is the same on both devices before checking it?

@sahiliamsso

This comment has been minimized.

Contributor

sahiliamsso commented Sep 25, 2018

@natt-tester - Please check on c6 instance

@natt-tester

This comment has been minimized.

natt-tester commented Sep 25, 2018

@sahiliamsso, @yurem, checked on c6 -- it works.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment