Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Determine facter version in order to prepare right command option #1465

Closed
yurem opened this issue Jan 17, 2019 · 0 comments

Comments

@yurem
Copy link
Contributor

commented Jan 17, 2019

In 3.1.5 we added new factor support here. New code do the next

attempt_to_execute('facter –show-legacy');
if exit_code is 0:
  parse_output
else:
  attempt_to_execute('facter');
  if exit_code is 0:
    parse_output

We need to run facter --version first time and run again facter with proper parameter.

@yurem yurem added this to the 4.0 milestone Jan 17, 2019

@yurem yurem self-assigned this Jan 17, 2019

@yurem yurem modified the milestones: 4.0, 3.1.6 Jan 23, 2019

@syntrydy syntrydy self-assigned this Feb 4, 2019

syntrydy added a commit that referenced this issue Feb 4, 2019

Merge pull request #1498 from /issues/1465
Determine facter version in order to prepare right command option #1465

@syntrydy syntrydy closed this Feb 4, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.