New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Automatically install all of our pre-built extensions #237

Merged
merged 1 commit into from Mar 22, 2017

Conversation

Projects
None yet
4 participants
@chingor13
Member

chingor13 commented Mar 22, 2017

Automatically install our extensions built as debian packages when we install php.

This will allow the users to only have to enable them by adding a custom php.ini file rather than forcing them to create a Dockerfile.

@googlebot googlebot added the cla: yes label Mar 22, 2017

@chingor13 chingor13 changed the title from Automatically install all of our pre-built extensions when we install… to Automatically install all of our pre-built extensions Mar 22, 2017

@chingor13 chingor13 merged commit 500b0c2 into master Mar 22, 2017

2 checks passed

ci/circleci Your tests passed on CircleCI!
Details
cla/google All necessary CLAs are signed

@chingor13 chingor13 deleted the autoinstall_extensions branch Mar 22, 2017

@chingor13 chingor13 referenced this pull request Mar 22, 2017

Merged

Phalcon #229

@jaitaiwan

This comment has been minimized.

Contributor

jaitaiwan commented Mar 22, 2017

So just clarifying, this will allow the extensions to be installed with a custom ini?

@chingor13

This comment has been minimized.

Member

chingor13 commented Mar 22, 2017

When the new runtime is released, yes. I'll create a new release when it's available (hopefully today).

@chingor13

This comment has been minimized.

Member

chingor13 commented Mar 23, 2017

@jaitaiwan This is released. Official docs are still being worked on.

@jaitaiwan

This comment has been minimized.

Contributor

jaitaiwan commented Mar 23, 2017

Cheers @chingor13. I just pulled the latest docker image to test. Are the extensions being placed in a non-std folder? I get this error message when I try it: PHP Startup: Unable to load dynamic library '/opt/php71/lib/x86_64-linux-gnu/extensions/no-debug-non-zts-20160303/phalcon.so'

@chingor13

This comment has been minimized.

Member

chingor13 commented Mar 23, 2017

The phalcon project only currently supports PHP 5.5, 5.6, and 7.0 - so it's only available for app engine flex on 5.6 and 7.0. You can specify your PHP version in your composer.json file.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment