The overall Governance umbrella project web site.
HTML CSS Ruby
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
_includes
_layouts
css
dtgov
getinvolved
img
js
lib/bootstrap-3.1.1
rtgov
s-ramp
.gitignore
.project
CNAME
Gemfile
README.md
_config.yml
index.html
pom.xml

README.md

governance.github.io

The overall Overlord project web site.

Local Testing

To locally build and test this site, there are a few prereqs:

  1. Install Ruby 1.9.3 or 2.0.0.
  2. Install ruby-devel (Fedora), ruby[version]-dev (Debian-based), or an equivalent for other systems. Without it, you'll get errors about a missing header file, etc.
  3. Install gcc
  4. Install a JavaScript runtime (nodejs)
  5. gem install bundler
  6. bundle install (within the Governance.github.io dir)

To run the site (http://localhost:4000): bundle exec jekyll server