Skip to content
This repository

NodeJS style IO for jetpack

tree: 3f2c7344d0

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 @modules
Octocat-spinner-32 raw.github.com
Octocat-spinner-32 .gitignore
Octocat-spinner-32 .gitmodules
Octocat-spinner-32 History.md
Octocat-spinner-32 Readme.md
Octocat-spinner-32 buffer.js
Octocat-spinner-32 fs.js
Octocat-spinner-32 io.js
Octocat-spinner-32 net.js
Octocat-spinner-32 package.json
Octocat-spinner-32 stream.js
Readme.md

fs

NodeJS filesystem API for Jetpack.

Install

To use this package you will need [npm][http://npmjs.org/] and graphquire.

git clone git://github.com/Gozala/jetpack-io.git
cd jetpack-io
npm install graphquire -g
npm link

Use

You can use this package with a help of graphquire. To do so just use one of the following requires in your module:

require('https://raw.github.com/Gozala/jetpack-io/v0.1.0/fs.js')
require('https://raw.github.com/Gozala/jetpack-io/v0.1.0/net.js')
require('https://raw.github.com/Gozala/jetpack-io/v0.1.0/stream.js')

And make sure to run npm link in your project before running.

Alternatively you can install package as described in a previous section and use this it as a dependency.

Something went wrong with that request. Please try again.