New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Broken link to API browser in main menu #2586

Closed
hc4 opened this Issue Aug 2, 2016 · 5 comments

Comments

Projects
None yet
4 participants
@hc4
Contributor

hc4 commented Aug 2, 2016

Problem description

image

Environment

  • Graylog Version: 2.1.0-beta1
@joschi

This comment has been minimized.

Contributor

joschi commented Aug 2, 2016

@hc4 Could you please post your rest_listen_uri, rest_transport_uri, web_listen_uri, and web_endpoint_uri settings?
Are you using the X-Graylog-Server-URL request header?

@hc4

This comment has been minimized.

Contributor

hc4 commented Aug 2, 2016

rest_listen_uri = http://0.0.0.0:12900/
rest_transport_uri not set
web_listen_uri = http://127.0.0.1:80/
web_endpoint_uri not set

headers

GET / HTTP/1.1
Host: graylog
Connection: keep-alive
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Upgrade-Insecure-Requests: 1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 YaBrowser/16.3.0.7843 Safari/537.36
Accept-Encoding: gzip, deflate, sdch
Accept-Language: ru,en;q=0.8
@edmundoa

This comment has been minimized.

Member

edmundoa commented Aug 2, 2016

Thank you for reporting this issue!

I have been trying to reproduce this behaviour, but it seems it was fixed in #2564.
We will release another beta shortly, I'll close the issue, please take a look on beta 2 and reopen it if you still see the problem.

@edmundoa edmundoa closed this Aug 2, 2016

@edmundoa

This comment has been minimized.

Member

edmundoa commented Aug 2, 2016

Sorry, my bad, the linked issue didn't fix this.

@edmundoa edmundoa reopened this Aug 2, 2016

@edmundoa edmundoa self-assigned this Aug 2, 2016

@edmundoa edmundoa added the bug label Aug 2, 2016

@edmundoa edmundoa added this to the 2.1.0 milestone Aug 2, 2016

@edmundoa edmundoa added the web label Aug 2, 2016

@bernd

This comment has been minimized.

Member

bernd commented Aug 3, 2016

Fixed via #2587

@bernd bernd closed this Aug 3, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment