New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Search Query Flashes Login Prompt Briefly #2770

Closed
eroji opened this Issue Sep 2, 2016 · 4 comments

Comments

Projects
None yet
6 participants
@eroji

eroji commented Sep 2, 2016

After upgrading to Graylog 2.1.0, all search queries flashes the login prompt briefly as it reloads the screen with the results.

We are using Graylog on an input server and a web frontend server set as slave and serving only the web interface using Apache proxy to HTTPS. I verified that even with no Apache proxy, the behavior is the same.

Steps to Reproduce (for bugs)

Click on the magnifying glass or type in parameter to perform the search

Your Environment

  • Graylog Version: 2.1.0
  • Elasticsearch Version: 2.0.5
  • MongoDB Version: 3.2
  • Operating System: CentOS 6.7
  • Browser version: Chrome 52 / IE 11.0
@twgraham

This comment has been minimized.

Contributor

twgraham commented Sep 5, 2016

I was getting this issue before 2.1, though I think it may be more prominent in 2.1. At first I put it down to latency since I was trying to hit my Graylog cluster on east coast USA from Australia, but now I get it when running as local docker environment too.

@nilroy

This comment has been minimized.

nilroy commented Sep 6, 2016

I have not seen this issue in 2.0.x but I upgraded to 2.1.0 and getting this issue.

@edmundoa

This comment has been minimized.

Member

edmundoa commented Sep 6, 2016

The flashing is somehow intended when you do a full reload of the page (or there is a redirection that triggers it, like the form that is submitted when searching). Anyway, I think we can mitigate at least part of the annoyance of that flashing:

  • Remove the unnecessary redirections or submits we do in the web interface (#2488)
  • Change the page we display while validating the user's credentials (responsible of this flashing), so it doesn't look exactly like the login form

I think the second change is small enough that we can put it in a patch release, and it can already avoid some confusion around this.

@edmundoa edmundoa self-assigned this Sep 6, 2016

edmundoa added a commit that referenced this issue Sep 9, 2016

Show loading page while validating session
This displays a loading page while we validate the user session, instead
of showing the login form.

Refs #2770

@edmundoa edmundoa added this to the 2.1.1 milestone Sep 9, 2016

@jalogisch jalogisch added bug S4 P4 labels Sep 12, 2016

dennisoelkers added a commit that referenced this issue Sep 12, 2016

Do not display login form while loading (#2802)
* Display loading page while loading user information

Refs #2770

* Show loading page while validating session

This displays a loading page while we validate the user session, instead
of showing the login form.

Refs #2770

* Remove unnecessary div

dennisoelkers added a commit that referenced this issue Sep 12, 2016

Do not display login form while loading (#2802)
* Display loading page while loading user information

Refs #2770

* Show loading page while validating session

This displays a loading page while we validate the user session, instead
of showing the login form.

Refs #2770

* Remove unnecessary div

(cherry picked from commit a1c337b)
@edmundoa

This comment has been minimized.

Member

edmundoa commented Sep 12, 2016

This has been fixed in #2802

@edmundoa edmundoa closed this Sep 12, 2016

@kroepke kroepke added triaged and removed triaged labels Sep 21, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment