New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Copy query button does not work #3491

Closed
edmundoa opened this Issue Feb 14, 2017 · 1 comment

Comments

Projects
None yet
3 participants
@edmundoa
Member

edmundoa commented Feb 14, 2017

On Graylog 2.2.0, opening the show query modal dialogue and clicking on "Copy query" is not working as expected. This problem is not happening in all copy to clipboard buttons, the one copying the message ID is working.

Expected Behavior

Clicking on "Copy query" should copy the ES query to the clipboard.

Current Behavior

Clicking on "Copy query" does not copy anything to the clipboard.

Steps to Reproduce (for bugs)

  1. Open search page
  2. Click on More actions -> Show query
  3. Click on Copy query
  4. See that the query was not copied to your clipboard

Your Environment

  • Graylog Version: 2.2.0
  • Operating System: macOS and Linux
  • Browser version: Latest Firefox and Chrome. The issue cannot be reproduced in Safari, though.

@edmundoa edmundoa added the bug label Feb 14, 2017

@jalogisch jalogisch added the triaged label Feb 20, 2017

@billmurrin billmurrin referenced this issue Feb 26, 2017

Merged

Copy Query Button Fix (#3491) #3548

3 of 9 tasks complete
@dennisoelkers

This comment has been minimized.

Member

dennisoelkers commented Mar 9, 2017

Fixed in #3548

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment