New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Import extractors returns NPE #942

Closed
edmundoa opened this Issue Feb 4, 2015 · 2 comments

Comments

Projects
None yet
3 participants
@edmundoa
Member

edmundoa commented Feb 4, 2015

Using 1.0.0-rc.2, importing extractors may fail with a NPE.

@edmundoa edmundoa added the bug label Feb 4, 2015

@edmundoa edmundoa added this to the 1.0.0 milestone Feb 4, 2015

@edmundoa edmundoa self-assigned this Feb 4, 2015

@bernd

This comment has been minimized.

Member

bernd commented Feb 4, 2015

I was able to import the apache and heroku extractors from graylog.org, but the clavister one did not work. It seems to have a broken converters section. (3 with empty {} and one with a broken date type config)

Nevertheless, our code should somehow handle this or at least provide a better error message.

Tested with 1.0.0-rc.2.

@edmundoa

This comment has been minimized.

Member

edmundoa commented Feb 13, 2015

Fixed with changes in PRs #960 and graylog-labs/graylog2-web-interface#1115.

@edmundoa edmundoa closed this Feb 13, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment