Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Ensure that plugin RPMs will be built for Linux #3658

Merged
merged 1 commit into from Mar 29, 2017
Merged

Conversation

@joschi
Copy link
Contributor

@joschi joschi commented Mar 27, 2017

RPM packages built using the graylog-plugin-parent POM were using the build OS's name for the %{OS} attribute in the RPM, e. g. "mac os x" if the package was built on Mac OS X.

This lead to problems when trying to install these packages on Linux, where rpm complained with:

package $NAME is intended for a different operating system

Setting the targetOS attribute of the rpm-maven-plugin to linux solves the issue.

Fixes #3657

@joschi joschi added this to the 2.3.0 milestone Mar 27, 2017
@dennisoelkers dennisoelkers merged commit b7b3383 into master Mar 29, 2017
3 checks passed
Loading
@dennisoelkers dennisoelkers deleted the issue-3657 branch Mar 29, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants