Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Flash 10 compatability #5

Open
aaronbrashears opened this Issue Jun 30, 2010 · 1 comment

Comments

Projects
None yet
2 participants

I installed the plug-in as described and went to the page where I added the s3 uploader and found this message:

Please Update your Flash Player to Flash v9.0.1 or higher...

I checked at adobe ( http://kb2.adobe.com/cps/155/tn_15507.html ) and found I have player version 'MAC 10,1,53,64' which is Flash 10. The javascript appears to be doing the version parsing and checking though I cannot figure out where the check happens. Is it possible that it is doing a string compare and therefore 10 < 9 in that check?

The demo site ( http://demo-s3-swf-upload.heroku.com/ ) appears to load the flash content. Is there some other potential error causing this message?

Owner

GreenAsJade commented Jun 30, 2010

Regrettably its the flash plugin itself doing this, as far as I know. I too have not found any code making this check: it's inside Flash. These sorts of issues dog the use of Flash, I regret I don't have an easy answer.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment