New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Problem with frozen array on modular-scale gem #183

Closed
joelchristopher opened this Issue Jan 14, 2014 · 26 comments

Comments

Projects
None yet
@joelchristopher

joelchristopher commented Jan 14, 2014

I am just testing out Gumby on Mac OS X dev environment.
Trying to run command:
compass watch and getting returned this error:

RuntimeError on line ["122"] of /Users/myuser/Projects/projectdir/sass/extensions/modular-scale/lib/modular-scale.rb: can't modify frozen Array

I also installed the ruby gem locally and updating config.rb but that returns the same result.
Any ideas?

@danhere

This comment has been minimized.

Show comment
Hide comment
@danhere

danhere Jan 14, 2014

Member

What version of the gems Gumby requires are you running? And your Ruby version?

Member

danhere commented Jan 14, 2014

What version of the gems Gumby requires are you running? And your Ruby version?

@joelchristopher

This comment has been minimized.

Show comment
Hide comment
@joelchristopher

joelchristopher Jan 14, 2014

I have installed:

gumby 2.6
ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-darwin12.0]
modular-scale (1.0.6)
compass (0.13.alpha.12, 0.12.2)
sass (3.3.0.rc.2, 3.2.13)
sassy-math (1.5)

It looks to me though like the config.rb file settings are referencing the extensions gumby includes by default.
Excerpt from config.rb:

extensions_dir = "sass/extensions"
Compass::Frameworks.register('modular-scale', :path => File.expand_path("#{extensions_dir}/modular-scale"))

Let me see what version is included by default with gumby...

joelchristopher commented Jan 14, 2014

I have installed:

gumby 2.6
ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-darwin12.0]
modular-scale (1.0.6)
compass (0.13.alpha.12, 0.12.2)
sass (3.3.0.rc.2, 3.2.13)
sassy-math (1.5)

It looks to me though like the config.rb file settings are referencing the extensions gumby includes by default.
Excerpt from config.rb:

extensions_dir = "sass/extensions"
Compass::Frameworks.register('modular-scale', :path => File.expand_path("#{extensions_dir}/modular-scale"))

Let me see what version is included by default with gumby...

@danhere

This comment has been minimized.

Show comment
Hide comment
@danhere

danhere Jan 14, 2014

Member

Right. We had to bundle the gems because we had quite a bit of fuss raised by users who either were unable to or afraid to install the gems locally. Commenting the Compass::Frameworks... line out and un-commenting out the require statement for modular-scale below it will tell compass to use the system gem, rather than the bundled one.

Member

danhere commented Jan 14, 2014

Right. We had to bundle the gems because we had quite a bit of fuss raised by users who either were unable to or afraid to install the gems locally. Commenting the Compass::Frameworks... line out and un-commenting out the require statement for modular-scale below it will tell compass to use the system gem, rather than the bundled one.

@joelchristopher

This comment has been minimized.

Show comment
Hide comment
@joelchristopher

joelchristopher Jan 14, 2014

Yeah, I tried commenting out and using my system installed gems but was getting same result.
Do I need to do anything to re-initialize the changes once I update the config.rb file?

joelchristopher commented Jan 14, 2014

Yeah, I tried commenting out and using my system installed gems but was getting same result.
Do I need to do anything to re-initialize the changes once I update the config.rb file?

@danhere

This comment has been minimized.

Show comment
Hide comment
@danhere

danhere Jan 14, 2014

Member

No, you should just be able to run compass compile. I wonder if it has anything to do with the fact that you're using a RC version of sass. I would try removing that next and see where that gets you.

Member

danhere commented Jan 14, 2014

No, you should just be able to run compass compile. I wonder if it has anything to do with the fact that you're using a RC version of sass. I would try removing that next and see where that gets you.

@joelchristopher

This comment has been minimized.

Show comment
Hide comment
@joelchristopher

joelchristopher Jan 14, 2014

Yeah, I was wondering about that too. Okay -- I will try that next.

joelchristopher commented Jan 14, 2014

Yeah, I was wondering about that too. Okay -- I will try that next.

@joelchristopher

This comment has been minimized.

Show comment
Hide comment
@joelchristopher

joelchristopher Jan 14, 2014

Downgraded to version 3.2.13... which does seem like a good idea to try... but now I've broken dependencies to deal with. /.rvm/rubies/ruby-2.1.0/lib/ruby/site_ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'sass' (~> 3.3.0.rc.1) - did find: sass-3.2.13.

Maybe I need to roll my version of ruby back too now. ?

I guess I'll keep pursuing this path for a bit and can hopefully get it sorted.
Will let you now if the version of Sass was the issue.

joelchristopher commented Jan 14, 2014

Downgraded to version 3.2.13... which does seem like a good idea to try... but now I've broken dependencies to deal with. /.rvm/rubies/ruby-2.1.0/lib/ruby/site_ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'sass' (~> 3.3.0.rc.1) - did find: sass-3.2.13.

Maybe I need to roll my version of ruby back too now. ?

I guess I'll keep pursuing this path for a bit and can hopefully get it sorted.
Will let you now if the version of Sass was the issue.

@joelchristopher

This comment has been minimized.

Show comment
Hide comment
@joelchristopher

joelchristopher Jan 14, 2014

Thanks for pointing me in the right direction. After re-installing rvm, gems, etc I got it working. So, finding stable / compatible versions of the ruby components looks like it did the trick. Cheers!

joelchristopher commented Jan 14, 2014

Thanks for pointing me in the right direction. After re-installing rvm, gems, etc I got it working. So, finding stable / compatible versions of the ruby components looks like it did the trick. Cheers!

@danhere

This comment has been minimized.

Show comment
Hide comment
@danhere

danhere Jan 14, 2014

Member

No problem! Seems to be one of the drawbacks of living on the bleeding edge of new tech 😥. Anyways glad to here you got it all figured out. Have fun!

Member

danhere commented Jan 14, 2014

No problem! Seems to be one of the drawbacks of living on the bleeding edge of new tech 😥. Anyways glad to here you got it all figured out. Have fun!

@danhere danhere closed this Jan 14, 2014

@martynassateika

This comment has been minimized.

Show comment
Hide comment
@martynassateika

martynassateika Aug 21, 2014

Sorry for bringing up an old thread, but @joelchristopher, could you please tell me the version numbers of the gems you had in the end? I ran into he exact same problem when trying to "compass compile" Gumby's .scss files.

martynassateika commented Aug 21, 2014

Sorry for bringing up an old thread, but @joelchristopher, could you please tell me the version numbers of the gems you had in the end? I ran into he exact same problem when trying to "compass compile" Gumby's .scss files.

@aforward

This comment has been minimized.

Show comment
Hide comment
@aforward

aforward Aug 24, 2014

@marcinkonys here my Gemfile which resolved the issue above.

source 'https://rubygems.org'

gem "rb-readline", "0.4.2"
gem "pure-sass"
gem "string-encrypt"
gem "i18n", '0.6.9'
gem "modular-scale", '~> 1.0.6'
gem "sassy-math"
gem "bundler", "~> 1.3"
gem "rake", ">= 10.0.4"
gem "compass", ">= 0"

# This is the new bundler dependency I added to downgrade from sass 3.4
gem "sass", "~> 3.2.13"

aforward commented Aug 24, 2014

@marcinkonys here my Gemfile which resolved the issue above.

source 'https://rubygems.org'

gem "rb-readline", "0.4.2"
gem "pure-sass"
gem "string-encrypt"
gem "i18n", '0.6.9'
gem "modular-scale", '~> 1.0.6'
gem "sassy-math"
gem "bundler", "~> 1.3"
gem "rake", ">= 10.0.4"
gem "compass", ">= 0"

# This is the new bundler dependency I added to downgrade from sass 3.4
gem "sass", "~> 3.2.13"
@craigkeller

This comment has been minimized.

Show comment
Hide comment
@craigkeller

craigkeller Aug 25, 2014

Member

Just submitted a pull request to fix this.

Member

craigkeller commented Aug 25, 2014

Just submitted a pull request to fix this.

@sumanjitsg

This comment has been minimized.

Show comment
Hide comment
@sumanjitsg

sumanjitsg Aug 31, 2014

@craigkeller Trying since last evening .. updated gumby with bower, installed sass 3.4.1, compass 1.0.1, modular-scale 2.0.5 .. nothing works .. finally after so many searches and hit and trials, got that working great with sass 3.2.19, compass 0.12.6 and modular scale 1.0.6 ..

Cherishing Gumby .. waiting for Gumby 3 !!! 👍

sumanjitsg commented Aug 31, 2014

@craigkeller Trying since last evening .. updated gumby with bower, installed sass 3.4.1, compass 1.0.1, modular-scale 2.0.5 .. nothing works .. finally after so many searches and hit and trials, got that working great with sass 3.2.19, compass 0.12.6 and modular scale 1.0.6 ..

Cherishing Gumby .. waiting for Gumby 3 !!! 👍

@joeldenning

This comment has been minimized.

Show comment
Hide comment
@joeldenning

joeldenning Sep 1, 2014

@luvdjkaran09 did you try "bower install gumby#master"? It is different than "bower install gumby" because the bower.json file references a specific commit from 6 months ago (which doesn't include the recent commit by @craigkeller). Once I tried that, I was able to run "compass compile" and everything worked just fine.

@craigkeller Thanks for the fix -- saved me some time figuring out how to fix it myself.

joeldenning commented Sep 1, 2014

@luvdjkaran09 did you try "bower install gumby#master"? It is different than "bower install gumby" because the bower.json file references a specific commit from 6 months ago (which doesn't include the recent commit by @craigkeller). Once I tried that, I was able to run "compass compile" and everything worked just fine.

@craigkeller Thanks for the fix -- saved me some time figuring out how to fix it myself.

@Petrella

This comment has been minimized.

Show comment
Hide comment
@Petrella

Petrella Sep 3, 2014

I've got the same issue with gumby and I'm kind of new to gumby though I know about sass and compass:

  1. tried to install gumby with claymate install: modular-scale.rb:122:in `delete_if': can't modify frozen Array
  2. tried all the hints from above, nothing helped
  3. tried to switch all versions as mentioned
  4. tried to use gumby#master
  5. still the same error

Is there any other solution to this error? Is there any bulletproof combination of compass, sass, modular-scale ??

Anyway: compass compile runs through perfect but not claymate!

I also double checked the versions:

Sass: 3.4.2
compass: 1.1.0
modular-scale: 2.0.5

Still no change, same error.

Petrella commented Sep 3, 2014

I've got the same issue with gumby and I'm kind of new to gumby though I know about sass and compass:

  1. tried to install gumby with claymate install: modular-scale.rb:122:in `delete_if': can't modify frozen Array
  2. tried all the hints from above, nothing helped
  3. tried to switch all versions as mentioned
  4. tried to use gumby#master
  5. still the same error

Is there any other solution to this error? Is there any bulletproof combination of compass, sass, modular-scale ??

Anyway: compass compile runs through perfect but not claymate!

I also double checked the versions:

Sass: 3.4.2
compass: 1.1.0
modular-scale: 2.0.5

Still no change, same error.

@corycollier

This comment has been minimized.

Show comment
Hide comment
@corycollier

corycollier Sep 3, 2014

I'm having this same problem on a project that's a couple of years old. I'm trying to dust it off, and after upgrading, I'm getting this error.

Any solutions are super-welcome ;)

corycollier commented Sep 3, 2014

I'm having this same problem on a project that's a couple of years old. I'm trying to dust it off, and after upgrading, I'm getting this error.

Any solutions are super-welcome ;)

@ARolek

This comment has been minimized.

Show comment
Hide comment
@ARolek

ARolek Sep 16, 2014

I'm also having this problem. I'm using Compass 1.1.0.alpha.2 (Polaris)

Here's my output from gem list --local:

animation (0.1.alpha.3)
bigdecimal (1.2.4)
bundler (1.6.2)
bundler-unload (1.0.2)
chunky_png (1.3.1)
compass (1.1.0.alpha.2, 1.1.0.alpha.1, 1.0.1)
compass-core (1.1.0.alpha.2, 1.1.0.alpha.1, 1.0.1)
compass-import-once (1.0.5)
executable-hooks (1.3.2)
ffi (1.9.3)
gem-wrappers (1.2.4)
io-console (0.4.2)
json (1.8.1)
minitest (4.7.5)
modular-scale (2.0.5)
multi_json (1.10.1)
psych (2.0.5)
rake (10.1.0)
rb-fsevent (0.9.4)
rb-inotify (0.9.5)
rdoc (4.1.0)
rubygems-bundler (1.4.4)
rvm (1.11.3.9)
sass (3.4.3)
test-unit (2.1.2.0)

Any ideas?

ARolek commented Sep 16, 2014

I'm also having this problem. I'm using Compass 1.1.0.alpha.2 (Polaris)

Here's my output from gem list --local:

animation (0.1.alpha.3)
bigdecimal (1.2.4)
bundler (1.6.2)
bundler-unload (1.0.2)
chunky_png (1.3.1)
compass (1.1.0.alpha.2, 1.1.0.alpha.1, 1.0.1)
compass-core (1.1.0.alpha.2, 1.1.0.alpha.1, 1.0.1)
compass-import-once (1.0.5)
executable-hooks (1.3.2)
ffi (1.9.3)
gem-wrappers (1.2.4)
io-console (0.4.2)
json (1.8.1)
minitest (4.7.5)
modular-scale (2.0.5)
multi_json (1.10.1)
psych (2.0.5)
rake (10.1.0)
rb-fsevent (0.9.4)
rb-inotify (0.9.5)
rdoc (4.1.0)
rubygems-bundler (1.4.4)
rvm (1.11.3.9)
sass (3.4.3)
test-unit (2.1.2.0)

Any ideas?

@ARolek

This comment has been minimized.

Show comment
Hide comment
@ARolek

ARolek Sep 16, 2014

@luvdjkaran09 comment saved the day! Gumby is reliant on very specific versions of software, and does not play well with the newer versions of the dependencies. The software I installed is as follows:

ruby 1.9.3
sass 3.2.19
compass 0.12.6 
modular scale 1.0.6

Everything works great now.

ARolek commented Sep 16, 2014

@luvdjkaran09 comment saved the day! Gumby is reliant on very specific versions of software, and does not play well with the newer versions of the dependencies. The software I installed is as follows:

ruby 1.9.3
sass 3.2.19
compass 0.12.6 
modular scale 1.0.6

Everything works great now.

@tlimited

This comment has been minimized.

Show comment
Hide comment
@tlimited

tlimited Oct 23, 2014

Ah, finally! Started getting googly eyes of all the googling.. Thanks to @ARolek to point out what @luvdjkaran09 had found (but I didn't see at first). Downgrading sass, compass and modular scale worked!
PS, didn't have to downgrade ruby.

Here's for you newbies, for easy execution run these and input "y" when asked to really uninstall because of dependencies:
sudo gem uninstall modular-scale
sudo gem install modular-scale -v 1.0.6
sudo gem uninstall sass
sudo gem install sass -v 3.2.19
sudo gem uninstall compass
sudo gem install compass -v 0.12.6

tlimited commented Oct 23, 2014

Ah, finally! Started getting googly eyes of all the googling.. Thanks to @ARolek to point out what @luvdjkaran09 had found (but I didn't see at first). Downgrading sass, compass and modular scale worked!
PS, didn't have to downgrade ruby.

Here's for you newbies, for easy execution run these and input "y" when asked to really uninstall because of dependencies:
sudo gem uninstall modular-scale
sudo gem install modular-scale -v 1.0.6
sudo gem uninstall sass
sudo gem install sass -v 3.2.19
sudo gem uninstall compass
sudo gem install compass -v 0.12.6

@frizbee

This comment has been minimized.

Show comment
Hide comment
@frizbee

frizbee Nov 7, 2014

Thank to @ARolek @tlimited after fresh install Yosemite with vagrant had same problem, so I downgraded sass to 3.2.19 and compass 0.12.6
It worked!!!!

frizbee commented Nov 7, 2014

Thank to @ARolek @tlimited after fresh install Yosemite with vagrant had same problem, so I downgraded sass to 3.2.19 and compass 0.12.6
It worked!!!!

@ApXaHgheJI

This comment has been minimized.

Show comment
Hide comment
@ApXaHgheJI

ApXaHgheJI Nov 11, 2014

@tlimited tnx, working for me ! best regards.

ApXaHgheJI commented Nov 11, 2014

@tlimited tnx, working for me ! best regards.

@odonohueben

This comment has been minimized.

Show comment
Hide comment
@odonohueben

odonohueben Nov 14, 2014

Thanks @tlimited My problem is now fixed..

odonohueben commented Nov 14, 2014

Thanks @tlimited My problem is now fixed..

@tamarmot

This comment has been minimized.

Show comment
Hide comment
@tamarmot

tamarmot Jan 6, 2015

Unfortunately I am having the same problem, but I am trying to use django-pipeline-compass to compile. It seems that django-pipeline-compass includes an incomaptible version of compass. I can't be the first one to use django pipeline to compile gumby, how has this problem been solved? Thanks.

tamarmot commented Jan 6, 2015

Unfortunately I am having the same problem, but I am trying to use django-pipeline-compass to compile. It seems that django-pipeline-compass includes an incomaptible version of compass. I can't be the first one to use django pipeline to compile gumby, how has this problem been solved? Thanks.

@timbo61

This comment has been minimized.

Show comment
Hide comment
@timbo61

timbo61 Mar 27, 2015

Thank you tlimited. It's taken me ALL day to get to this point but your suggested versions worked a treat!:-

"Here's for you newbies, for easy execution run these and input "y" when asked to really uninstall because of dependencies:
sudo gem uninstall modular-scale
sudo gem install modular-scale -v 1.0.6
sudo gem uninstall sass
sudo gem install sass -v 3.2.19
sudo gem uninstall compass
sudo gem install compass -v 0.12.6"

timbo61 commented Mar 27, 2015

Thank you tlimited. It's taken me ALL day to get to this point but your suggested versions worked a treat!:-

"Here's for you newbies, for easy execution run these and input "y" when asked to really uninstall because of dependencies:
sudo gem uninstall modular-scale
sudo gem install modular-scale -v 1.0.6
sudo gem uninstall sass
sudo gem install sass -v 3.2.19
sudo gem uninstall compass
sudo gem install compass -v 0.12.6"

@sneppa

This comment has been minimized.

Show comment
Hide comment
@sneppa

sneppa Jun 15, 2015

@ARolek, thanks, you saved me a lot of time!
Works perfect with this versions:
rvm (1.11.3.9)
compass (0.12.6)
modular-scale (1.0.6)
sass (3.2.19)
sassy-math (1.5.1)

sneppa commented Jun 15, 2015

@ARolek, thanks, you saved me a lot of time!
Works perfect with this versions:
rvm (1.11.3.9)
compass (0.12.6)
modular-scale (1.0.6)
sass (3.2.19)
sassy-math (1.5.1)

@micschk

This comment has been minimized.

Show comment
Hide comment
@micschk

micschk Oct 7, 2015

As the web is moving on, the gems installed are likely newer thatn those required by Gumby. I have good results by installing the older ones side by side, and then specifying which version of compass to use:

Install commands:

sudo gem install modular-scale -v 1.0.6
sudo gem install sass -v 3.2.19
sudo gem install compass -v 0.12.6"

And use compass 0.12.6:

%> compass _0.12.6_ watch

micschk commented Oct 7, 2015

As the web is moving on, the gems installed are likely newer thatn those required by Gumby. I have good results by installing the older ones side by side, and then specifying which version of compass to use:

Install commands:

sudo gem install modular-scale -v 1.0.6
sudo gem install sass -v 3.2.19
sudo gem install compass -v 0.12.6"

And use compass 0.12.6:

%> compass _0.12.6_ watch
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment