Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Aliases to private services don't autocomplete #943

Closed
weaverryan opened this issue Jun 1, 2017 · 2 comments
Closed

Aliases to private services don't autocomplete #943

weaverryan opened this issue Jun 1, 2017 · 2 comments
Labels

Comments

@weaverryan
Copy link
Sponsor

weaverryan commented Jun 1, 2017

Hi guys!

We just got a question on KnpU about why (at least in 3.3) $this->container->get('templating') does not auto-complete and reports as a "missing service".

The reason is that templating is an alias to templating.engine.twig and templating.engine.twig is a private service. When I manually change templating.engine.twig to public, auto-completion works instantly.

Is it possible that the plugin is incorrectly hiding an alias if the final service is private? The alias itself can be public/private, and that should be used.

Thanks!

Haehnchen added a commit that referenced this issue Jun 3, 2017
… safety for Symfony 3.3 private service debugger #618 #943
Haehnchen added a commit that referenced this issue Jun 3, 2017
… safety for Symfony 3.3 private service debugger #618 #943
@Haehnchen Haehnchen added the fixed label Jun 3, 2017
@Haehnchen
Copy link
Owner

Haehnchen commented Jun 3, 2017

reworked appDevDebugProjectContainer.xml handling with #618. also tested against Symfony 3.3 and templating is working.

@weaverryan
Copy link
Sponsor Author

weaverryan commented Aug 15, 2017

Indeed fixed! Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

2 participants