Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade Lua to 5.3 and enable compilation #90

Closed
ghost opened this issue Oct 23, 2018 · 1 comment

Comments

Projects
None yet
1 participant
@ghost
Copy link

commented Oct 23, 2018

Please upgrade the Lua interpreter to Lua 5.3 if possible and enable it in the compiler.py script by differentiating between LuaJIT and Lua 5.3 via an additional file extension, e.g. .lua53 or .luajit.

LuaJIT implements most of Lua 5.2 already, Lua 5.3 is the current standard and has been released over three years ago.

lidavidm pushed a commit that referenced this issue Oct 27, 2018

@lidavidm lidavidm referenced this issue Oct 27, 2018

Merged

Misc fixes #105

@lidavidm

This comment has been minimized.

Copy link
Contributor

commented Oct 30, 2018

Lua 5.3 should now be available. Submit a MyBot.lua53.

@lidavidm lidavidm closed this Oct 30, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.