New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Crash when video preview is started while encode is happening #1683

Open
Nomis101 opened this Issue Nov 16, 2018 · 1 comment

Comments

4 participants
@Nomis101
Copy link
Contributor

Nomis101 commented Nov 16, 2018

Description of the problem

If I start a video encode in HEVC and than open the live preview, HandBrake crashes. This is happening on Mac. I've tested the same on Windows 10 and it did not crash.

Steps to reproduce the problem

  1. Start HandBrake for Mac and choose a video file to encode
  2. Apply a HEVC preset, like "Apple 2160p60 4k HEVC Surround" (disable subtitles so encode will start faster) and start the encode, wait until the encode has started
  3. Open the preview window and start the live preview
    --> The progress indicator for the live preview window will appear, than HandBrake crashes

HandBrake version (e.g., 1.0.0)

HandBrake-20181115140404-d8d6646-master

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update)

macOS 10.14

Error message text or screenshot

Apple crash log is attached
HandBrake_2018-11-16-214449_polysoms-MacBook-Pro.crash.tar.gz

@bradleysepos

This comment has been minimized.

Copy link
Member

bradleysepos commented Nov 16, 2018

This is a known issue with the x265 codec, which is not re-entrant. I believe @galad87 is working on it.

@bradleysepos bradleysepos added this to the 1.3.0 milestone Nov 16, 2018

@sr55 sr55 modified the milestones: 1.3.0, Unscheduled Jan 1, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment