New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

handbrake update 1.20 (DPL2 Audio Issue) #1756

Open
twingreen36 opened this Issue Dec 26, 2018 · 30 comments

Comments

4 participants
@twingreen36
Copy link

twingreen36 commented Dec 26, 2018

Description of the problem

at the moment of converting a mkv movie with the default parameters when playing it on a plasma TV the audio is scratched

@sr55

This comment has been minimized.

Copy link
Member

sr55 commented Dec 26, 2018

To re-iterate, we can't help you unless you fill out all the details in the post template.

The following information is still required:

Operating system and version (e.g., Ubuntu 18.04 LTS, macOS 10.14 Mojave, Windows 10 1809)

Please replace this text with the version of the operation system you are running.

Error message text or screenshot

Please provide any error messages or screenshots that may help.

HandBrake Activity Log (see https://handbrake.fr/docs/en/latest/help/activity-log.html)

Please replace this text with the Activity log, or upload the log file to Github by dropping the file on this post.
Leave the ~ marks above and below.
@fprietog

This comment has been minimized.

Copy link

fprietog commented Dec 26, 2018

Probably duplicated of #1744

In that issue I said The AAC wrong track is played "garbled" in VLC but the words "scratched" or "scrambled" are also adequate (sorry but english is not my primary language so I use a translator for that).

@twingreen36 please publish the mediainfo of both files: original and converted.

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 27, 2018

I have installed 64-bit window 7, the problem is not when playing it on my computer, it sounds good. if not when playing it on my plasma TV through the USB port the audio distorts ...scratch as in reverse
![01](
01

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 27, 2018

with the previous version this did not happen
02

@twingreen36

This comment has been minimized.

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 27, 2018

try what I say brother to convert a mkv movie with aac audio and then play it on a plasma tv, lsd or smartv via the usb port ,with this version HandBrake 1.1.2 Released , it does not harm that problem although there were many improvements

@sr55

This comment has been minimized.

Copy link
Member

sr55 commented Dec 27, 2018

Can you try mixdown Stereo to see if the problem goes away?

Failing all that, a short sample video file if you could share, would be good.

@sr55 sr55 changed the title handbrake update 1.20 handbrake update 1.20 (DPL2 Audio Issue) Dec 27, 2018

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 28, 2018

probe with the mixdown in stereo and nothing here is the video
https://drive.google.com/file/d/1iPvDe7wqzulU9YaOyIAs6GEYvoBkuEfN/view

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 28, 2018

with the previous version this did not happen when playing on the plasma TV through the USB port....... thanks for answering

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 28, 2018

I hope you can fix it as soon as possible in the next update

@sr55

This comment has been minimized.

Copy link
Member

sr55 commented Dec 28, 2018

I'm not sure what we can really do here. I have no way to reproduce this. Everything I have plays the files HandBrake produces with the config from your log without issue. It's also odd that only your TV has the problem. It could be some kind of bug in the TV also that's being triggered by some change. Unfortunately without being able to re-create, it doesn't bode well for any kind of resolution.

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 29, 2018

but with the previous version this did not happen

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 29, 2018

they changed the library Libav for FFmpeg
Right

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 29, 2018

There's the problem, brother.

@sr55

This comment has been minimized.

Copy link
Member

sr55 commented Dec 29, 2018

What makes you think ffmpeg is the problem?

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 29, 2018

because the previous version was the library Libav and it will not be heard when playing it well I think it's nobody but that I think

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 29, 2018

what possibilities and that in the next update I would have a codec HE-AAC maybe too fraunhofer fdk aac

@sr55

This comment has been minimized.

Copy link
Member

sr55 commented Dec 29, 2018

That doesn't mean ffmpeg is to blame. Unless you've gone and used ffmpeg CLI to encode the same thing and can reproduce the issue with that tool, it could be a fairly large number of things.

There is no license compatible HE-AAC encoder we can use. FDK is not license compatible unfortunately so it won't make it into an official release. Technically you can compile from source with it included but that's non trivial.

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 30, 2018

You can solve it by selecting the automatic passthru
default
, but not the way when saving the configuration.

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 30, 2018

if not there is a way to be putting every time I cast a movie so that it remains in AAC the autopassthru

@sr55

This comment has been minimized.

Copy link
Member

sr55 commented Dec 30, 2018

ON the defaults screen, if you set the first track to auto passthru there, save

Then save a new preset in the main window, those settings will always take effect when you have your new preset selected, or you make it default

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 30, 2018

How can I make a film that has dimensions 720x480p to be in 16: 9 scale?

@twingreen36

This comment has been minimized.

Copy link

twingreen36 commented Dec 30, 2018

thanks for always answering

@sr55

This comment has been minimized.

Copy link
Member

sr55 commented Dec 30, 2018

If your looking for support, your better off looking at our documentation (https://handbrake.fr/docs/) and community forums.

@alissa914

This comment has been minimized.

Copy link

alissa914 commented Jan 13, 2019

I can say that with 1.12 that I did not have popping audio in the output streams periodically on my iPod Classic. None at all.

Windows 10 Home (1809) 17763.253 (no Insider builds)

After upgrading to 1.2, I made an M4V file from a BluRay (Region B) to 720x576 PAL encoded file and played on my iPod Classic on ATSC (USA) TV set. The video played fine but the audio has periodic pops and crackle noises that do not exist in the original video stream. I was playing the disc in Daum PotPlayer and heard no "digital errors" in the LPCM stream from the BluRay (Travelers (Season 1) - Region B) but the output audio clearly has errors in the stream. I'm downgrading back to 1.12 ..... (no errors reported in the log from the 1.2 version which is below). If this is related to what you posted above about changing an AV library, then you may have an issue there that someone should try to replicate. If someone has Travelers: Season 1 on BluRay with the LPCM track, try encoding it down to 160kbps AAC stereo (and I can't do LPCM pass-through for an iPod nor would I since it takes up way too much space for me):

18:12:58] job configuration:
[18:12:58]  * source
[18:12:58]    + E:\
[18:12:58]    + title 5, chapter(s) 1 to 5
[18:12:58]  * destination
[18:12:58]    + N:\Dropbox\iTunes\iTunes Media\Automatically Add to iTunes\Dazb0441 D1-5.m4v
[18:12:58]    + container: MPEG-4 (libavformat)
[18:12:58]      + compatibility atom for iPod 5G
[18:12:58]      + align initial A/V stream timestamps
[18:12:58]      + chapter markers
[18:12:58]  * video track
[18:12:58]    + decoder: h264
[18:12:58]      + bitrate 200 kbps
[18:12:58]    + filters
[18:12:58]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[18:12:58]      + Decomb (mode=39)
[18:12:58]      + Framerate Shaper (mode=2:rate=27000000/1080000)
[18:12:58]        + frame rate: 25.000 fps -> peak rate limited to 25.000 fps
[18:12:58]      + Crop and Scale (width=720:height=576:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[18:12:58]        + source: 1920 * 1080, crop (0/0/0/0): 1920 * 1080, scale: 720 * 576
[18:12:58]    + Output geometry
[18:12:58]      + storage dimensions: 720 x 576
[18:12:58]      + pixel aspect ratio: 64 : 45
[18:12:58]      + display dimensions: 1024 x 576
[18:12:58]    + encoder: H.264 (libx264)
[18:12:58]      + preset:  slow
[18:12:58]      + profile: baseline
[18:12:58]      + level:   3.0
[18:12:58]      + quality: 22.00 (RF)
[18:12:58]      + color profile: 1-1-1
[18:12:58]  * audio track 1
[18:12:58]    + decoder: English (BD LPCM) (2.0 ch) (track 1, id 0x1100)
[18:12:58]      + bitrate: 2304 kbps, samplerate: 48000 Hz
[18:12:58]    + mixdown: Stereo
[18:12:58]    + dither: none
[18:12:58]    + encoder: AAC (libavcodec)
[18:12:58]      + bitrate: 160 kbps, samplerate: 48000 Hz
[18:12:58] sync: expecting 66384 video frames
[18:12:58] encx264: encoding at constant RF 22.000000
[18:12:58] encx264: unparsed options: level=3.0:ref=5:bframes=0:cabac=0:8x8dct=0:weightp=0:subme=8:trellis=2:vbv-bufsize=10000:vbv-maxrate=10000:rc-lookahead=50
x264 [info]: using SAR=64/45
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
x264 [info]: profile Constrained Baseline, level 3.0, 4:2:0, 8-bit
[18:12:58] sync: first pts audio 0x1100 is 0
[18:12:58] sync: first pts video is 0
[18:12:58] sync: "Chapter 1" (1) at frame 1 time 0
[18:21:32] sync: "Chapter 2" (2) at frame 16414 time 59086800
[18:29:56] sync: "Chapter 3" (3) at frame 32061 time 115416000
[18:39:59] sync: "Chapter 4" (4) at frame 49149 time 176932800
[18:49:06] bd: End of title
@alissa914

This comment has been minimized.

Copy link

alissa914 commented Jan 13, 2019

How can I make a film that has dimensions 720x480p to be in 16: 9 scale?

Anamorphic mode: Automatic. It depends on playback device. iPod has no issues with it and I've made anamorphic 16:9 videos at 720x576 or 720x480 with no problems. Zune won't adhere to the aspect ratio and always plays in 1:1. I assume a few others do as well.

@sr55

This comment has been minimized.

Copy link
Member

sr55 commented Jan 13, 2019

Are you able to provide a sample that exhibits the problem and if possible, also a source clip?

@alissa914

This comment has been minimized.

Copy link

alissa914 commented Jan 13, 2019

@alissa914

This comment has been minimized.

Copy link

alissa914 commented Jan 13, 2019

Guess the JSON file didn't make it in the email reply.
BluRay PAL.zip

@sr55

This comment has been minimized.

Copy link
Member

sr55 commented Jan 16, 2019

The file that crackles on the ipod. Same thing if you play the same file in VLC?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment