Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[MacGUI] Reload button doesn't work after job was sent back from queue #2227

Open
Nomis101 opened this issue Aug 7, 2019 · 6 comments

Comments

@Nomis101
Copy link
Contributor

commented Aug 7, 2019

Description of the problem

Steps:

  1. Open a file in HandBrake and select your standard preset
  2. Modify something, e.g. select Denoise or sharpen filter
    -> You will see the (Modified) next to the presets name
  3. Click "Add to queue"
  4. Open the new queue window
  5. Now recognize that you (accidentally) modified your preset. So click "Edit" in the new queue Window to send the job back to the Main Window.
  6. Click the "Reload" button to set the preset to the default
    -> Nothing happens

HandBrake version (e.g., 1.0.0)

Version 20190805100506-4ba75f9-master (2019080601)

Operating system and version (e.g., Ubuntu 18.04 LTS, macOS 10.14 Mojave, Windows 10 1809)

macOS 10.14 Mojave

@sr55 sr55 added the Bug label Aug 7, 2019

@sr55 sr55 added this to the 1.3.0 milestone Aug 7, 2019

@galad87

This comment has been minimized.

Copy link
Contributor

commented Aug 7, 2019

Jobs in the queue don't store the original preset.

@sr55

This comment has been minimized.

Copy link
Contributor

commented Aug 7, 2019

Would "reload" not load back to whatever is selected regardless of what the queue job used as a preset?

@Nomis101

This comment has been minimized.

Copy link
Contributor Author

commented Aug 7, 2019

Hm, my assumption how the "reload" button works was, that it "de-modifies" the current selected preset. Doesn't it?

@sr55

This comment has been minimized.

Copy link
Contributor

commented Aug 7, 2019

Yup.

@Nomis101

This comment has been minimized.

Copy link
Contributor Author

commented Aug 7, 2019

Good. And this doesn't seem to work after putting the job back from the queue. It still does say "(modified)" regardless how often I hit the "Reload" button.

@marxspawn

This comment has been minimized.

Copy link

commented Aug 14, 2019

Tried to replicate the bug Nomis101 reported, using macOS Mojave 10.14.5.

  • I loaded a video and chose my preset.
    • Modified the video dimensions to display the preset as modified for first run.
    • Modified the encoder setting on second run
  • Added each modified version to que separately.
  • Selected the edit job settings from the que list, then selected the reload button.

1st Run

  • The preset did still display as (Modified), but the video dimensions were reset back to the original 1920 x 800.

2nd Run

  • The preset remained (Modified) and also did not return to the original encoder setting.

Work-around

  • Select a different preset.
  • Next, re-select the desired preset.
    • Both the (Modified) tag and the actual presets are reset back to their original state.

Hope this helps.

Great app btw 👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
4 participants
You can’t perform that action at this time.