New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Crash on startup on Windows 10 #789

Closed
d4rkne55 opened this Issue Jun 17, 2017 · 5 comments

Comments

Projects
None yet
4 participants
@d4rkne55

d4rkne55 commented Jun 17, 2017

Please describe the problem or feature request in detail:

I had Handbrake v0.10.5 and v1.0.2 installed simultaneously and everything worked fine back then.
Just some days ago I uninstalled v.0.10.5 and since then I couldn't start Handbrake (v1.0.2) anymore. I then tried uninstalling that too, backing up and removing the AppData folder (not the whole folder of course, just the Handbrake folder^^) and do a clean install of the current v1.0.7. But well, that didn't help at all, I even did a restart. It's just crashing immediately, I don't even get to see something.

What are the steps to reproduce this problem:

/

What version of HandBrake are you running:

1.0.2 & 1.0.7

What operating system and version are you running (e.g. OSX 10.11, Windows 7, Ubuntu 14):

Windows 10, recently installed the new Creators Update (build #1703)

Was there any error message or error dialog, if so please detail or provide screenshots:

/

Please provide the full activity log for the encode or scan attempt. You may attach the log as a file, post a pastebin URL to the log, or place the log inline below:

The activity logs are empty, well, of course. I couldn't do anything.
But I can provide you a crash dump I found under %localappdata%/CrashDumps:
https://files.fm/u/6sxc4xd7

@sr55

This comment has been minimized.

Show comment
Hide comment
@sr55

sr55 Jun 17, 2017

Member

Running multiple versions is not supported and will lead to the 2 versions overwriting and corrupting presets and to a lesser extent settings.

It could be a coincidence. If you've cleared all files and it's not working, if you have RivaTuner installed, add an exception for HandBrake as it doesn't interact well with creators update and it kills many apps that hook DirectX.

Member

sr55 commented Jun 17, 2017

Running multiple versions is not supported and will lead to the 2 versions overwriting and corrupting presets and to a lesser extent settings.

It could be a coincidence. If you've cleared all files and it's not working, if you have RivaTuner installed, add an exception for HandBrake as it doesn't interact well with creators update and it kills many apps that hook DirectX.

@d4rkne55

This comment has been minimized.

Show comment
Hide comment
@d4rkne55

d4rkne55 Jun 17, 2017

It worked nice though, as far as I could tell. But yeah, normally one should run only one version, I just wanted to compare them because of the large version bump.^^

Thanks for the tip regarding RivaTuner though, I have MSI Afterburner and RivaTuner always running, could be the problem here, I'll give it a try in a moment. :)

Update: Wow, awesome, it worked! :D Should be noted somewhere officially or would you not say so? I'm not the only one using MSI Afterburner/RivaTuner. ;)

d4rkne55 commented Jun 17, 2017

It worked nice though, as far as I could tell. But yeah, normally one should run only one version, I just wanted to compare them because of the large version bump.^^

Thanks for the tip regarding RivaTuner though, I have MSI Afterburner and RivaTuner always running, could be the problem here, I'll give it a try in a moment. :)

Update: Wow, awesome, it worked! :D Should be noted somewhere officially or would you not say so? I'm not the only one using MSI Afterburner/RivaTuner. ;)

@d4rkne55 d4rkne55 closed this Jun 17, 2017

@sr55

This comment has been minimized.

Show comment
Hide comment
@sr55

sr55 Jun 17, 2017

Member

I was hoping people would fix their buggy software but apparently not :(

Member

sr55 commented Jun 17, 2017

I was hoping people would fix their buggy software but apparently not :(

@bradleysepos

This comment has been minimized.

Show comment
Hide comment
@bradleysepos

bradleysepos Jun 17, 2017

Contributor

Yeah, we should probably put a notice somewhere about RivaTuner. I'll see about adding it to the documentation.

Contributor

bradleysepos commented Jun 17, 2017

Yeah, we should probably put a notice somewhere about RivaTuner. I'll see about adding it to the documentation.

@mgstraze

This comment has been minimized.

Show comment
Hide comment
@mgstraze

mgstraze Jan 31, 2018

I was having the same problem (Handbrake won't start). Adding an exception to RivaTuner solved it. Thanks.

mgstraze commented Jan 31, 2018

I was having the same problem (Handbrake won't start). Adding an exception to RivaTuner solved it. Thanks.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment