Skip to content

Release Notes

This version contains security fixes to prevent possible XSS attacks as described in #1441. They don't relate to user data submitted to Hangfire directly via method arguments, but it's recommended to upgrade anyway. If you are using Hangfire 1.7, please upgrade to version 1.7.3 instead.

Affected Packages
Hangfire.Core ≤ 1.6.25, 1.7.0, 1.7.1, 1.7.2
Affected Platforms
All, including .NET Core, .NET Framework, Mono of any version

Steps to reproduce

public static void Xss()
{
    BackgroundJob.Enqueue(() => Xss2());
}

public static void Xss2()
{
    throw new Exception("<script>alert(1);</script>");
}

Hangfire.Core

  • SECURITY – Use HtmlEncode in all remaining places in Dashboard UI to prevent XSS attacks.
Assets 3
You can’t perform that action at this time.