Permalink
Find file
Fetching contributors…
Cannot retrieve contributors at this time
108 lines (107 sloc) 2.38 KB
{
"name": "mern-cli",
"version": "3.0.1",
"description": "A cli for generating MERN boilerplate",
"main": "index.js",
"watch": {
"compile": "src/**/*.js"
},
"scripts": {
"compile": "babel --presets es2015,stage-0 -d lib/ src/",
"lint": "eslint . --ignore-path .gitignore",
"lint:staged": "eslint-staged",
"prepublish": "npm run compile",
"pretest": "npm run lint",
"test": "ava tests/*.js",
"watch": "npm-watch"
},
"pre-commit": "lint:staged && npm run test",
"eslintConfig": {
"parser": "babel-eslint",
"extends": "airbnb-base",
"env": {
"node": true,
"es6": true,
"shelljs": true
},
"parserOptions": {
"ecmaVersion": 6,
"sourceType": "module"
},
"rules": {
"import/no-unresolved": 2,
"global-require": 0,
"comma-dangle": [
2,
"always-multiline"
],
"indent": [
2,
4,
{
"SwitchCase": 1
}
],
"max-len": 0,
"no-console": 0,
"prefer-template": 2,
"no-use-before-define": 0,
"newline-per-chained-call": 0,
"arrow-body-style": [
2,
"as-needed"
]
}
},
"engines": {
"node": ">=4"
},
"repository": {
"type": "git",
"url": "git+https://github.com/Hashnode/mern-cli.git"
},
"keywords": [
"cli",
"mern",
"isomorphic",
"boilerplate",
"react",
"redux",
"react-router",
"express",
"mongo"
],
"author": "Mayank Chandola <imayankchd@gmail.com>, Prashant Abhishek <prashant.abhishek7g@gmail.com>",
"license": "MIT",
"bugs": {
"url": "https://github.com/Hashnode/mern-cli/issues"
},
"homepage": "https://github.com/Hashnode/mern-cli#readme",
"bin": {
"mern": "./bin/mern.js",
"merng": "./bin/merng.js"
},
"dependencies": {
"chalk": "^1.1.1",
"cli-table": "^0.3.1",
"commander": "^2.9.0",
"ejs": "^2.4.1",
"elegant-spinner": "^1.0.1",
"log-update": "^1.0.2",
"shelljs": "^0.6.0",
"writefile": "^0.2.8"
},
"devDependencies": {
"ava": "^0.11.0",
"babel-cli": "^6.9.0",
"babel-eslint": "^6.0.4",
"babel-preset-es2015": "^6.9.0",
"babel-preset-stage-0": "^6.5.0",
"eslint": "^2.10.2",
"eslint-config-airbnb-base": "^3.0.1",
"eslint-plugin-import": "^1.8.0",
"lint-staged": "^0.2.2",
"npm-watch": "^0.1.4",
"pify": "^2.3.0"
}
}