New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Reported wrong version of PostgreSQL #137

Closed
Ivan-Perez opened this Issue Feb 13, 2018 · 3 comments

Comments

Projects
None yet
3 participants
@Ivan-Perez

Ivan-Perez commented Feb 13, 2018

I'm connecting to a PostgreSQL server, version 10.2. HeidiSQL incorrectly reports it as PostreSQL 4.8.5, although on the ballon I can see the correct version. Maybe this is only a parse problem, so it could be fixed easily.

Context

  • HeidiSQL version: 9.5.0.5245
  • Database system + version: PostgreSQL 10.2 on CentOS 7
  • Operating system: Windows 7

sin titulo

@rentalhost rentalhost added the bug label Feb 13, 2018

@rentalhost

This comment has been minimized.

Collaborator

rentalhost commented Feb 13, 2018

Seems like it is reading the Red Hat version instead of database system.

@ansgarbecker

This comment has been minimized.

Collaborator

ansgarbecker commented Feb 13, 2018

Should be fixed in the next nightly build.

ansgarbecker added a commit that referenced this issue Feb 14, 2018

Fix detection of PostgreSQL version ignoring the 3rd version segment,…
… and use the same logic as for MySQL again. See issue #137.
@Ivan-Perez

This comment has been minimized.

Ivan-Perez commented Feb 14, 2018

Thanks!

@ansgarbecker ansgarbecker added this to the v9.6 milestone Feb 18, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment