Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

slaveclone bug and last permanently when triggered using autobonus #2531

Open
Emistry opened this issue Sep 3, 2019 · 0 comments

Comments

@Emistry
Copy link
Member

commented Sep 3, 2019

Describe the bug
only first clone will behave correctly, will auto attack
any other clones after the first one will only stand there like a statue, and doesn't attack.
however, all the clones doesn't vanish after 1minute if i recall correctly they should have 1 minute lifespan by default.
@slaveclone become not usable anymore.

To Reproduce
Steps to reproduce the behavior:

  1. add this script for any equipment (I was using this in a costume equipments)
	Script: <"
		autobonus "{ atcommand \"@slaveclone \"+strcharinfo(0); }",1000,60000;
	">
  1. equip the item, then summon alot monster to kills.
  2. when the clones start attacking monster, keep switch equipment so that the autobonus get triggered again whenever you re-equip any other equipments.
  3. the item bonus keep triggered and keep spawn clones.
  4. player can no longer use @slaveclone since it hit the slave limit and it doesn't reduce over time.

Expected behavior
Clone shouldn't standstill like a statue
Clone should vanish after 1 minute by default if not mistaken
@slaveclone shouldn't fail since it should recover the clone limit over time.

Screenshots
If applicable, add screenshots to help explain your problem.
img
re-equip any kind of equipments will allow the autobonus to re-triggers again and again.

System specs (please complete the following information):

  • OS: [e.g. windows 10 version 1809, macOS 10.14]
  • Hercules Version [e.g. v2018.08.25]
  • Mode: [renewal]
  • Packet version: [e.g. 20180624]
  • Client type: [e.g. RE]

@Emistry Emistry changed the title slaveclone last permanent when trigger by autobonus slaveclone broken and last permanent and broken when triggered by autobonus Sep 3, 2019

@Emistry Emistry changed the title slaveclone broken and last permanent and broken when triggered by autobonus slaveclone bug and last permanently when triggered using autobonus Sep 3, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.