Why my "pod search HMSegmentedControl" is still version 1.3.0? #77

Closed
dabing1022 opened this Issue Dec 25, 2014 · 3 comments

Comments

Projects
None yet
2 participants
@dabing1022
➜  ~  pod search HMSegmentedControl


-> HMSegmentedControl (1.3.0)
   A drop-in replacement for UISegmentedControl mimicking the style of the one
   in Google Currents and various other Google products.
   pod 'HMSegmentedControl', '~> 1.3.0'
   - Homepage: https://github.com/HeshamMegid/HMSegmentedControl
   - Source:   https://github.com/HeshamMegid/HMSegmentedControl.git
   - Versions: 1.3.0, 1.2.0, 1.1.0, 1.0.0 [master repo]

OSX : 10.9.5

Cocoapods Version:

➜  ~  pod --version
0.33.1

Any ideas? Thanks in advance:]

@dabing1022

This comment has been minimized.

Show comment
Hide comment
@dabing1022

dabing1022 Dec 25, 2014

So, of course, when I write pod 'HMSegmentedControl', '~> 1.4.0' in Podfile, and execute "pod install", it'll show error

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `HMSegmentedControl (~> 1.4.0)` required by `Podfile`

So, of course, when I write pod 'HMSegmentedControl', '~> 1.4.0' in Podfile, and execute "pod install", it'll show error

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `HMSegmentedControl (~> 1.4.0)` required by `Podfile`
@HeshamMegid

This comment has been minimized.

Show comment
Hide comment
@HeshamMegid

HeshamMegid Dec 25, 2014

Owner

pod search HMSegmentedControl show 1.4.0 here.

I doubt that's the issue, but try updating to the latest Cocoapods version.

Owner

HeshamMegid commented Dec 25, 2014

pod search HMSegmentedControl show 1.4.0 here.

I doubt that's the issue, but try updating to the latest Cocoapods version.

@dabing1022

This comment has been minimized.

Show comment
Hide comment
@dabing1022

dabing1022 Dec 26, 2014

Thanks, @HeshamMegid !
I resolve it according to your suggestion.

Here is the way.

1. update cocoapods to the latest version

$ sudo gem update --system
$ sudo gem install cocoapods
$ pod setup

2. pod --version shows 0.35.0 higher than 0.33.1.

3. pod search HMSegmentedControl in terminal

$ pod search HMSegmentedControl
HMSegmentedControl (1.4.0)
   A drop-in replacement for UISegmentedControl mimicking the style of the one
   in Google Currents and various other Google products.
   pod 'HMSegmentedControl', '~> 1.4.0'
   - Homepage: https://github.com/HeshamMegid/HMSegmentedControl
   - Source:   https://github.com/HeshamMegid/HMSegmentedControl.git
   - Versions: 1.4.0, 1.3.0, 1.2.0, 1.1.0, 1.0.0 [master repo]

Thanks, @HeshamMegid !
I resolve it according to your suggestion.

Here is the way.

1. update cocoapods to the latest version

$ sudo gem update --system
$ sudo gem install cocoapods
$ pod setup

2. pod --version shows 0.35.0 higher than 0.33.1.

3. pod search HMSegmentedControl in terminal

$ pod search HMSegmentedControl
HMSegmentedControl (1.4.0)
   A drop-in replacement for UISegmentedControl mimicking the style of the one
   in Google Currents and various other Google products.
   pod 'HMSegmentedControl', '~> 1.4.0'
   - Homepage: https://github.com/HeshamMegid/HMSegmentedControl
   - Source:   https://github.com/HeshamMegid/HMSegmentedControl.git
   - Versions: 1.4.0, 1.3.0, 1.2.0, 1.1.0, 1.0.0 [master repo]
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment