Skip to content

Broken on Gentoo #24

Closed
davedriver opened this Issue Aug 2, 2012 · 0 comments

2 participants

@davedriver

I've been trying to run rpi-update on a Gentoo system. I get the following error:

rpi / # rpi-update 240
Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS
Performing self-update
Using ARM/GPU memory split of 240MB/16MB
Updating firmware (this will take a few minutes)
Using HardFP libraries
../sysdeps/unix/sysv/linux/getpagesize.c:32: __getpagesize: Assertion `_rtld_global_ro._dl_pagesize != 0' failed.
/usr/bin/rpi-update: line 112: 1947 Aborted git --git-dir="//root/.rpi-firmware/.git" --work-tree="//root/.rpi-firmware" rev-parse master

After this, virtually no commands work, I can't even shut the system down.

rpi / # init 0
Inconsistency detected by ld.so: dl-fini.c: 197: _dl_fini: Assertion `ns != 0 || i == nloaded' failed!

It won't boot afterwards, it panics on boot and I have to reimage.

Any ideas?

Many thanks,
Dave.

@Hexxeh Hexxeh closed this Dec 25, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.