[MC 1.5] Could not pass event InventoryClickEvent #561

Open
mibby opened this Issue Mar 14, 2013 · 8 comments

Comments

Projects
None yet
3 participants

mibby commented Mar 14, 2013

Using latest spigot with snapshot protocol to support 1.5 clients.

2013-03-13 17:59:14 [SEVERE] Could not pass event InventoryClickEvent to LWC v4.3.1 (b840-git-MANUAL) (March 04, 2013)
org.bukkit.event.EventException
at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:427)
at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
at org.bukkit.plugin.TimedRegisteredListener.callEvent(TimedRegisteredListener.java:26)
at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:479)
at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:464)
at net.minecraft.server.v1_4_R1.PlayerConnection.a(PlayerConnection.java:1202)
at net.minecraft.server.v1_4_R1.Packet102WindowClick.handle(SourceFile:31)
at org.spigotmc.netty.NettyNetworkManager.b(NettyNetworkManager.java:174)
at net.minecraft.server.v1_4_R1.PlayerConnection.d(PlayerConnection.java:113)
at net.minecraft.server.v1_4_R1.ServerConnection.b(SourceFile:39)
at org.spigotmc.netty.NettyServerConnection.b(NettyServerConnection.java:67)
at net.minecraft.server.v1_4_R1.MinecraftServer.r(MinecraftServer.java:600)
at net.minecraft.server.v1_4_R1.DedicatedServer.r(DedicatedServer.java:228)
at net.minecraft.server.v1_4_R1.MinecraftServer.q(MinecraftServer.java:489)
at net.minecraft.server.v1_4_R1.MinecraftServer.run(MinecraftServer.java:421)
at net.minecraft.server.v1_4_R1.ThreadServerApplication.run(SourceFile:849)
Caused by: java.lang.ArrayIndexOutOfBoundsException

mbax commented Mar 14, 2013

There is no CraftBukkit for 1.5. Using a hacked protocol on a craftbukkit mod is going to produce unexpected problems. Not a LWC bug.

@mibby mibby closed this Mar 14, 2013

mibby commented Mar 14, 2013

Now using Project Ares's unofficial craftbukkit 1.5. I know these errors are technically not supported since the bukkit team hasn't released 1.5 builds yet, but I figured I might as well post these anyways. Sorry to have bothered any devs.

2013-03-13 18:57:30 [SEVERE] Could not pass event InventoryClickEvent to LWC v4.3.1 (b840-git-MANUAL) (March 04, 2013)
org.bukkit.event.EventException
at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:427)
at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:477)
at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:462)
at net.minecraft.server.v1_5pre_R1.PlayerConnection.a(PlayerConnection.java:1177)
at net.minecraft.server.v1_5pre_R1.Packet102WindowClick.handle(SourceFile:31)
at net.minecraft.server.v1_5pre_R1.NetworkManager.b(NetworkManager.java:292)
at net.minecraft.server.v1_5pre_R1.PlayerConnection.d(PlayerConnection.java:113)
at net.minecraft.server.v1_5pre_R1.ServerConnection.b(SourceFile:35)
at net.minecraft.server.v1_5pre_R1.DedicatedServerConnection.b(SourceFile:30)
at net.minecraft.server.v1_5pre_R1.MinecraftServer.r(MinecraftServer.java:588)
at net.minecraft.server.v1_5pre_R1.DedicatedServer.r(DedicatedServer.java:226)
at net.minecraft.server.v1_5pre_R1.MinecraftServer.q(MinecraftServer.java:484)
at net.minecraft.server.v1_5pre_R1.MinecraftServer.run(MinecraftServer.java:417)
at net.minecraft.server.v1_5pre_R1.ThreadServerApplication.run(SourceFile:573)
Caused by: java.lang.ArrayIndexOutOfBoundsException
... 14 more

@mibby mibby reopened this Mar 14, 2013

Owner

Hidendra commented Mar 14, 2013

Is there a download link for the version you are using?

Owner

Hidendra commented Mar 14, 2013

(craftbukkit 1.5)

Owner

Hidendra commented Mar 14, 2013

build 5 works fine for me, what are you doing to reproduce this? Tried everything I could it is working perfectly fine with just LWC on the server.

mbax commented Mar 14, 2013

@mibby is going around to projects demanding they update to his mod. Don't worry about it.

mibby commented Mar 14, 2013

@mbax: I am not demanding. I am simply reporting an error that may be there once bukkit updates to 1.5 so devs can get a head start in updating. If you don't like people reporting errors to devs, don't comment.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment