New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Global Common Events #273

Closed
RaythalosM opened this Issue May 24, 2015 · 5 comments

Comments

Projects
None yet
2 participants
@RaythalosM

RaythalosM commented May 24, 2015

Sorry if I'm being plain annoying; I only noticed there's an issue submission button after posting a comment in the relevant page.

Anyway, there's an issue with Global Common Events that happens when you load the game. Common Events that were marked with "global common event: non-blocking" will work properly when a message box is up on a New Game, but upon loading a game, the game will suddenly forget the "global common event: non-blocking" tag ever existed, and the common event stops working once message boxes are up.

I tried loading a game with the condition switch already activated, it didn't work.
I tried loading a game with the condition switch inactive, but activated after talking to an NPC, it still does not work. Both of these events work properly on a New Game, though.

Is this a known, unresolvable issue? If not, is there a way to fix it? I've been seeing a few people asking about it but never got an answer. Thanks in advance!

@HimeWorks

This comment has been minimized.

Member

HimeWorks commented May 25, 2015

Reporting bugs via comments is perfectly ok.
The issue tracker is mainly for on-going issues or things that require more detailed back-and-forth and involves a lot of text.

@HimeWorks

This comment has been minimized.

Member

HimeWorks commented May 25, 2015

I have created the following scenario:

Common event that simply prints "run" to the console.
It is conditioned on switch 6 as a parallel process

Event that will turn on switch 6, then display a message box saying "running"
The common event will now run.

Then I save the game and close the game.
I open the game again, load the save file, and the event continues to print "run"

I'm not sure if this accurately represents your situation, but it seems to be working for me.

@RaythalosM

This comment has been minimized.

RaythalosM commented May 25, 2015

That's close, but not quite.
The problem is, the event based on your example will not print run if the message box (in this case, the one saying "running") is up, which was my problem in the first place.

It goes like this based on your scenario. I started a new game with an event displaying a message box that says "running" which turns on a switch to run the common event that will continuously print run.

With the event active, I talk to the event that displays the message box that says "running", and it still prints "run" even with the message box up.

However, after saving, closing, and reloading, while the event still prints "run" in other occasions, it will not print "run" when the event displays the "running" message box.

@HimeWorks

This comment has been minimized.

Member

HimeWorks commented May 26, 2015

I have updated the script. See if that solves the problem.

@RaythalosM

This comment has been minimized.

RaythalosM commented May 27, 2015

Thank you very much! It works smoothly now.

@HimeWorks HimeWorks closed this May 30, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment