Skip to content

CocoaPods 0.17 #50

Merged
merged 4 commits into from Mar 29, 2013

3 participants

@fabiopelosin

This patch performs the following changes

  • Add support for CocoaPods 0.17
  • Ask to CocoaPods if an installation is needed providing support for teams which do not keep the Pods folder under version control.
  • Don't make assumptions about the paths of the files generated by CocoaPods (his assumption would have caused problems with the Sandbox folder reorganization).
$ bundle exec rake
[..snip…]
10 specifications (14 requirements), 0 failures, 0 errors

I've not tested an actual installation.

@alloy, @lrz

@alloy
HipByte member
alloy commented Mar 22, 2013

❤️

Very nice, thanks!

@siuying When you have a chance, would you mind running this against one of your apps?

@siuying
siuying commented Mar 24, 2013

I having problem building a project:

  1. Some pods failed to build from build errors
  2. I update the Rakefile gems config to remove/update those pods
  3. I bundle exec rake clean, delete the vendor/Pods/build* folder and then bundle exec rake

Usually if i done above I would have build successfully, but this time they just would not build the pods part, as if cocoapod do not exists.

@alloy
HipByte member
alloy commented Mar 24, 2013

@siuying Can you share your Pods config from your Rakefile?

@siuying
siuying commented Mar 25, 2013

To be exact, the problem is: when a build failure occurred, even I rake clean or rm -rf vendor/Pods/build* , motion-cocoapod will not rebuild the library.

To reproduce the issue:

  1. Have a pod that wont build in the rakefile (e.g. pod 'QuickDialog')
  2. run rake
  3. The build should fail
  4. Fix the pod with a proper version (e.g. pod 'QuickDialog', :head)
  5. run rake clean then rm -rf vendor/Pods/build* then rake
  6. The app should run

Expected result

  1. I run rake, motion-cocoapods should rebuild with changed pods, and run the simulator (as in motion-cocoapods 1.2.2 + cocoapods 0.16.x)

Actual result

  1. motion-cocoapods do not rebuild the Pod library
  2. I can work around this with remove the whole Pods/ folder

Gemfile

source "http://rubygems.org"

gem "motion-cocoapods", :git => "https://github.com/irrationalfab/motion-cocoapods.git", :ref => "bd3b0ea1449f0d144b0d314c4078502ee0edb0fd"
gem "cocoapods", '0.17.0.rc5'

Rakefile

# -*- coding: utf-8 -*-
$:.unshift("/Library/RubyMotion/lib")
require 'motion/project'
require 'bundler'
Bundler.require

Motion::Project::App.setup do |app|
  # Use `rake config' to see complete project settings.
  app.name = 'test'

  app.pods do 
    pod 'QuickDialog'
    # pod 'QuickDialog' , :head
  end
end
@alloy
HipByte member
alloy commented Mar 25, 2013

@siuying Great, thanks for the description!

@fabiopelosin

@siuying is the issue only related to building the Pods library? In other, words, is CocoaPods performing an installation before point 6?

@siuying
siuying commented Mar 26, 2013

it seems not:

euler:buildtest $ rake clean
Could not find json-1.7.7 in any of the sources
Run `bundle install` to install missing gems.
    Delete ./build
euler:buildtest $ bundle exec rake COCOAPODS_VERBOSE=1
Could not find json-1.7.7 in any of the sources
Run `bundle install` to install missing gems.

Finding Podfile changes
  - QuickDialog
     Build ./build/iPhoneSimulator-6.1-Development
   Compile ./app/app_delegate.rb
    Create ./build/iPhoneSimulator-6.1-Development/test.app
      Link ./build/iPhoneSimulator-6.1-Development/test.app/test
    Create ./build/iPhoneSimulator-6.1-Development/test.app/Info.plist
    Create ./build/iPhoneSimulator-6.1-Development/test.app/PkgInfo
      Copy ./resources/Default-568h@2x.png
    Create ./build/iPhoneSimulator-6.1-Development/test.dSYM
  Simulate ./build/iPhoneSimulator-6.1-Development/test.app
(main)> 2013-03-26 20:29:52.566 test[1767:c07] app_delegate.rb:3:in `application:didFinishLaunchingWithOptions:': uninitialized constant AppDelegate::QuickDialogController (NameError)
2013-03-26 20:29:52.568 test[1767:c07] *** Terminating app due to uncaught exception 'NameError', reason: 'app_delegate.rb:3:in `application:didFinishLaunchingWithOptions:': uninitialized constant AppDelegate::QuickDialogController (NameError)
'
*** First throw call stack:
(0x1809012 0x179e7e 0xd8b34 0x31f2 0x2fa5)
libc++abi.dylib: terminate called throwing an exception
*** simulator session ended with error: Error Domain=DTiPhoneSimulatorErrorDomain Code=1 "被模拟的应用程序已退出。" UserInfo=0x10011ae20 {NSLocalizedDescription=被模拟的应用程序已退出。, DTiPhoneSimulatorUnderlyingErrorCodeKey=-1}
rake aborted!
Command failed with status (1): [DYLD_FRAMEWORK_PATH="/Applications/Xcode.a...]
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils.rb:53:in `block in create_shell_runner'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils.rb:45:in `call'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils.rb:45:in `sh'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils_ext.rb:37:in `sh'
/Library/RubyMotion/lib/motion/project.rb:102:in `block in <top (required)>'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:246:in `call'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:246:in `block in execute'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:241:in `each'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:241:in `execute'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:184:in `block in invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:177:in `invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:205:in `block in invoke_prerequisites'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:203:in `each'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:203:in `invoke_prerequisites'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:183:in `block in invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:177:in `invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:170:in `invoke'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:143:in `invoke_task'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101:in `block (2 levels) in top_level'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101:in `each'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101:in `block in top_level'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:110:in `run_with_threads'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:95:in `top_level'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:73:in `block in run'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:160:in `standard_exception_handling'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:70:in `run'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/bin/ruby_noexec_wrapper:14:in `eval'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/bin/ruby_noexec_wrapper:14:in `<main>'
Tasks: TOP => default => simulator
(See full trace by running task with --trace)
euler:buildtest $ rm -rf vendor/Pods/build*
euler:buildtest $ bundle exec rake COCOAPODS_VERBOSE=1
Could not find json-1.7.7 in any of the sources
Run `bundle install` to install missing gems.

Finding Podfile changes
  - QuickDialog
     Build ./build/iPhoneSimulator-6.1-Development
  Simulate ./build/iPhoneSimulator-6.1-Development/test.app
(main)> 2013-03-26 20:30:45.624 test[1809:c07] app_delegate.rb:3:in `application:didFinishLaunchingWithOptions:': uninitialized constant AppDelegate::QuickDialogController (NameError)
2013-03-26 20:30:45.625 test[1809:c07] *** Terminating app due to uncaught exception 'NameError', reason: 'app_delegate.rb:3:in `application:didFinishLaunchingWithOptions:': uninitialized constant AppDelegate::QuickDialogController (NameError)
'
*** First throw call stack:
(0x1809012 0x179e7e 0xd8b34 0x31f2 0x2fa5)
libc++abi.dylib: terminate called throwing an exception
((null))> rake aborted!
Command failed with status (1): [DYLD_FRAMEWORK_PATH="/Applications/Xcode.a...]
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils.rb:53:in `block in create_shell_runner'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils.rb:45:in `call'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils.rb:45:in `sh'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils_ext.rb:37:in `sh'
/Library/RubyMotion/lib/motion/project.rb:102:in `block in <top (required)>'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:246:in `call'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:246:in `block in execute'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:241:in `each'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:241:in `execute'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:184:in `block in invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:177:in `invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:205:in `block in invoke_prerequisites'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:203:in `each'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:203:in `invoke_prerequisites'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:183:in `block in invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:177:in `invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:170:in `invoke'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:143:in `invoke_task'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101:in `block (2 levels) in top_level'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101:in `each'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101:in `block in top_level'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:110:in `run_with_threads'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:95:in `top_level'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:73:in `block in run'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:160:in `standard_exception_handling'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:70:in `run'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/bin/ruby_noexec_wrapper:14:in `eval'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/bin/ruby_noexec_wrapper:14:in `<main>'
Tasks: TOP => default => simulator
(See full trace by running task with --trace)

@fabiopelosin

The patch was vendoring the Pods project only during installation. @siuying Can you try with the last commit?

@siuying
siuying commented Mar 28, 2013

Now the pod will always link, but it seems it never update. Even I remove the vendor/Pods/QuickDialog folder and while vendor/build* folders, it never fetch the repo again. I will have to remove whole vendor/Pods folder.

euler:buildtest $ bundle exec rake clean COCOAPODS_VERBOSE=1
Could not find json-1.7.7 in any of the sources
Run `bundle install` to install missing gems.

Finding Podfile changes
  - QuickDialog
    Delete ./build
euler:buildtest $ rm -rf vendor/Pods/QuickDialog
euler:buildtest $ rm -rf vendor/Pods/build*
euler:buildtest $ bundle exec rake COCOAPODS_VERBOSE=1
Could not find json-1.7.7 in any of the sources
Run `bundle install` to install missing gems.

Finding Podfile changes
  - QuickDialog
     Build ./build/iPhoneSimulator-6.1-Development
     Build vendor/Pods
Build settings from command line:
    ARCHS = i386
    CONFIGURATION_BUILD_DIR = .build
    IPHONEOS_DEPLOYMENT_TARGET = 6.1
    SDKROOT = iphonesimulator6.1

=== BUILD NATIVE TARGET Pods OF PROJECT Pods WITH CONFIGURATION Release ===
Check dependencies

CompileC build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QMultilineElement.o QuickDialog/quickdialog/QMultilineElement.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
    cd /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods
    setenv LANG en_US.US-ASCII
    setenv PATH "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/Users/siuying/.rvm/gems/ruby-2.0.0-p0/bin:/usr/local/bin:/usr/local/heroku/bin:/Users/siuying/.rvm/gems/ruby-2.0.0-p0@global/bin:/Users/siuying/.rvm/rubies/ruby-2.0.0-p0/bin:/Users/siuying/.rvm/bin:/Users/siuying/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin"
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -x objective-c -arch i386 -fmessage-length=0 -std=gnu99 -Wno-trigraphs -fpascal-strings -Os -Wno-missing-field-initializers -Wno-missing-prototypes -Wno-return-type -Wno-implicit-atomic-properties -Wno-receiver-is-weak -Wformat -Wno-missing-braces -Wparentheses -Wswitch -Wno-unused-function -Wno-unused-label -Wno-unused-parameter -Wno-unused-variable -Wunused-value -Wno-empty-body -Wno-uninitialized -Wno-unknown-pragmas -Wno-shadow -Wno-four-char-constants -Wno-conversion -Wno-constant-conversion -Wno-int-conversion -Wno-enum-conversion -Wno-shorten-64-to-32 -Wpointer-sign -Wno-newline-eof -Wno-selector -Wno-strict-selector-match -Wno-undeclared-selector -Wno-deprecated-implementations -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator6.1.sdk -fexceptions -fasm-blocks -fstrict-aliasing -Wprotocol -Wdeprecated-declarations -g -Wno-sign-conversion -fobjc-abi-version=2 -fobjc-legacy-dispatch -mios-simulator-version-min=6.1 -iquote /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-generated-files.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-own-target-headers.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-all-target-headers.hmap -iquote /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-project-headers.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/.build/include -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/BuildHeaders -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/BuildHeaders/QuickDialog -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/DerivedSources/i386 -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/DerivedSources -F/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/.build -DNS_BLOCK_ASSERTIONS=1 -fobjc-arc -DOS_OBJECT_USE_OBJC=0 -include /var/folders/hv/ltv3r1vs6nq_6gfmq1bmky7r0000gn/C/com.apple.Xcode.501/SharedPrecompiledHeaders/Pods-prefix-evjtmqeqybnljwexgqdhsurfovqh/Pods-prefix.pch -MMD -MT dependencies -MF /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QMultilineElement.d --serialize-diagnostics /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QMultilineElement.dia -c /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/QuickDialog/quickdialog/QMultilineElement.m -o /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QMultilineElement.o
clang: error: no such file or directory: '/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/QuickDialog/quickdialog/QMultilineElement.m'
clang: error: no input files
Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang failed with exit code 1

CompileC build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QDynamicDataSection.o QuickDialog/quickdialog/QDynamicDataSection.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
    cd /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods
    setenv LANG en_US.US-ASCII
    setenv PATH "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/Users/siuying/.rvm/gems/ruby-2.0.0-p0/bin:/usr/local/bin:/usr/local/heroku/bin:/Users/siuying/.rvm/gems/ruby-2.0.0-p0@global/bin:/Users/siuying/.rvm/rubies/ruby-2.0.0-p0/bin:/Users/siuying/.rvm/bin:/Users/siuying/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin"
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -x objective-c -arch i386 -fmessage-length=0 -std=gnu99 -Wno-trigraphs -fpascal-strings -Os -Wno-missing-field-initializers -Wno-missing-prototypes -Wno-return-type -Wno-implicit-atomic-properties -Wno-receiver-is-weak -Wformat -Wno-missing-braces -Wparentheses -Wswitch -Wno-unused-function -Wno-unused-label -Wno-unused-parameter -Wno-unused-variable -Wunused-value -Wno-empty-body -Wno-uninitialized -Wno-unknown-pragmas -Wno-shadow -Wno-four-char-constants -Wno-conversion -Wno-constant-conversion -Wno-int-conversion -Wno-enum-conversion -Wno-shorten-64-to-32 -Wpointer-sign -Wno-newline-eof -Wno-selector -Wno-strict-selector-match -Wno-undeclared-selector -Wno-deprecated-implementations -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator6.1.sdk -fexceptions -fasm-blocks -fstrict-aliasing -Wprotocol -Wdeprecated-declarations -g -Wno-sign-conversion -fobjc-abi-version=2 -fobjc-legacy-dispatch -mios-simulator-version-min=6.1 -iquote /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-generated-files.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-own-target-headers.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-all-target-headers.hmap -iquote /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-project-headers.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/.build/include -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/BuildHeaders -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/BuildHeaders/QuickDialog -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/DerivedSources/i386 -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/DerivedSources -F/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/.build -DNS_BLOCK_ASSERTIONS=1 -fobjc-arc -DOS_OBJECT_USE_OBJC=0 -include /var/folders/hv/ltv3r1vs6nq_6gfmq1bmky7r0000gn/C/com.apple.Xcode.501/SharedPrecompiledHeaders/Pods-prefix-evjtmqeqybnljwexgqdhsurfovqh/Pods-prefix.pch -MMD -MT dependencies -MF /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QDynamicDataSection.d --serialize-diagnostics /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QDynamicDataSection.dia -c /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/QuickDialog/quickdialog/QDynamicDataSection.m -o /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QDynamicDataSection.o
clang: error: no such file or directory: '/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/QuickDialog/quickdialog/QDynamicDataSection.m'
clang: error: no input files
Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang failed with exit code 1

CompileC build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QBadgeTableCell.o QuickDialog/quickdialog/QBadgeTableCell.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
    cd /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods
    setenv LANG en_US.US-ASCII
    setenv PATH "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/Users/siuying/.rvm/gems/ruby-2.0.0-p0/bin:/usr/local/bin:/usr/local/heroku/bin:/Users/siuying/.rvm/gems/ruby-2.0.0-p0@global/bin:/Users/siuying/.rvm/rubies/ruby-2.0.0-p0/bin:/Users/siuying/.rvm/bin:/Users/siuying/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin"
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -x objective-c -arch i386 -fmessage-length=0 -std=gnu99 -Wno-trigraphs -fpascal-strings -Os -Wno-missing-field-initializers -Wno-missing-prototypes -Wno-return-type -Wno-implicit-atomic-properties -Wno-receiver-is-weak -Wformat -Wno-missing-braces -Wparentheses -Wswitch -Wno-unused-function -Wno-unused-label -Wno-unused-parameter -Wno-unused-variable -Wunused-value -Wno-empty-body -Wno-uninitialized -Wno-unknown-pragmas -Wno-shadow -Wno-four-char-constants -Wno-conversion -Wno-constant-conversion -Wno-int-conversion -Wno-enum-conversion -Wno-shorten-64-to-32 -Wpointer-sign -Wno-newline-eof -Wno-selector -Wno-strict-selector-match -Wno-undeclared-selector -Wno-deprecated-implementations -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator6.1.sdk -fexceptions -fasm-blocks -fstrict-aliasing -Wprotocol -Wdeprecated-declarations -g -Wno-sign-conversion -fobjc-abi-version=2 -fobjc-legacy-dispatch -mios-simulator-version-min=6.1 -iquote /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-generated-files.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-own-target-headers.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-all-target-headers.hmap -iquote /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-project-headers.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/.build/include -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/BuildHeaders -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/BuildHeaders/QuickDialog -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/DerivedSources/i386 -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/DerivedSources -F/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/.build -DNS_BLOCK_ASSERTIONS=1 -fobjc-arc -DOS_OBJECT_USE_OBJC=0 -include /var/folders/hv/ltv3r1vs6nq_6gfmq1bmky7r0000gn/C/com.apple.Xcode.501/SharedPrecompiledHeaders/Pods-prefix-evjtmqeqybnljwexgqdhsurfovqh/Pods-prefix.pch -MMD -MT dependencies -MF /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QBadgeTableCell.d --serialize-diagnostics /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QBadgeTableCell.dia -c /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/QuickDialog/quickdialog/QBadgeTableCell.m -o /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QBadgeTableCell.o
clang: error: no such file or directory: '/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/QuickDialog/quickdialog/QBadgeTableCell.m'
clang: error: no input files
Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang failed with exit code 1

CompileC build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QEntryElement.o QuickDialog/quickdialog/QEntryElement.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
    cd /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods
    setenv LANG en_US.US-ASCII
    setenv PATH "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/Users/siuying/.rvm/gems/ruby-2.0.0-p0/bin:/usr/local/bin:/usr/local/heroku/bin:/Users/siuying/.rvm/gems/ruby-2.0.0-p0@global/bin:/Users/siuying/.rvm/rubies/ruby-2.0.0-p0/bin:/Users/siuying/.rvm/bin:/Users/siuying/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin"
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -x objective-c -arch i386 -fmessage-length=0 -std=gnu99 -Wno-trigraphs -fpascal-strings -Os -Wno-missing-field-initializers -Wno-missing-prototypes -Wno-return-type -Wno-implicit-atomic-properties -Wno-receiver-is-weak -Wformat -Wno-missing-braces -Wparentheses -Wswitch -Wno-unused-function -Wno-unused-label -Wno-unused-parameter -Wno-unused-variable -Wunused-value -Wno-empty-body -Wno-uninitialized -Wno-unknown-pragmas -Wno-shadow -Wno-four-char-constants -Wno-conversion -Wno-constant-conversion -Wno-int-conversion -Wno-enum-conversion -Wno-shorten-64-to-32 -Wpointer-sign -Wno-newline-eof -Wno-selector -Wno-strict-selector-match -Wno-undeclared-selector -Wno-deprecated-implementations -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator6.1.sdk -fexceptions -fasm-blocks -fstrict-aliasing -Wprotocol -Wdeprecated-declarations -g -Wno-sign-conversion -fobjc-abi-version=2 -fobjc-legacy-dispatch -mios-simulator-version-min=6.1 -iquote /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-generated-files.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-own-target-headers.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-all-target-headers.hmap -iquote /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Pods-project-headers.hmap -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/.build/include -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/BuildHeaders -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/BuildHeaders/QuickDialog -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/DerivedSources/i386 -I/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/DerivedSources -F/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/.build -DNS_BLOCK_ASSERTIONS=1 -fobjc-arc -DOS_OBJECT_USE_OBJC=0 -include /var/folders/hv/ltv3r1vs6nq_6gfmq1bmky7r0000gn/C/com.apple.Xcode.501/SharedPrecompiledHeaders/Pods-prefix-evjtmqeqybnljwexgqdhsurfovqh/Pods-prefix.pch -MMD -MT dependencies -MF /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QEntryElement.d --serialize-diagnostics /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QEntryElement.dia -c /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/QuickDialog/quickdialog/QEntryElement.m -o /Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QEntryElement.o
clang: error: no such file or directory: '/Users/siuying/Documents/workspace/motion/buildtest/vendor/Pods/QuickDialog/quickdialog/QEntryElement.m'
clang: error: no input files
Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang failed with exit code 1


** BUILD FAILED **


The following build commands failed:
    CompileC build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QMultilineElement.o QuickDialog/quickdialog/QMultilineElement.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
    CompileC build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QDynamicDataSection.o QuickDialog/quickdialog/QDynamicDataSection.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
    CompileC build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QBadgeTableCell.o QuickDialog/quickdialog/QBadgeTableCell.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
    CompileC build/Pods.build/Release-iphonesimulator/Pods.build/Objects-normal/i386/QEntryElement.o QuickDialog/quickdialog/QEntryElement.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
(4 failures)
rake aborted!
Command failed with status (65): [/usr/bin/xcodebuild -project "Pods.xcodepr...]
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils.rb:53:in `block in create_shell_runner'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils.rb:45:in `call'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils.rb:45:in `sh'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/file_utils_ext.rb:37:in `sh'
/Library/RubyMotion/lib/motion/project/vendor.rb:163:in `block in build_xcode'
/Library/RubyMotion/lib/motion/project/vendor.rb:132:in `chdir'
/Library/RubyMotion/lib/motion/project/vendor.rb:132:in `build_xcode'
/Library/RubyMotion/lib/motion/project/vendor.rb:41:in `build'
/Library/RubyMotion/lib/motion/project/builder.rb:59:in `block in build'
/Library/RubyMotion/lib/motion/project/builder.rb:58:in `each'
/Library/RubyMotion/lib/motion/project/builder.rb:58:in `build'
/Library/RubyMotion/lib/motion/project/app.rb:72:in `build'
/Library/RubyMotion/lib/motion/project.rb:51:in `block (2 levels) in <top (required)>'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:246:in `call'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:246:in `block in execute'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:241:in `each'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:241:in `execute'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:184:in `block in invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:177:in `invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:205:in `block in invoke_prerequisites'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:203:in `each'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:203:in `invoke_prerequisites'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:183:in `block in invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:177:in `invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:205:in `block in invoke_prerequisites'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:203:in `each'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:203:in `invoke_prerequisites'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:183:in `block in invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:177:in `invoke_with_call_chain'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:170:in `invoke'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:143:in `invoke_task'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101:in `block (2 levels) in top_level'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101:in `each'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101:in `block in top_level'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:110:in `run_with_threads'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:95:in `top_level'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:73:in `block in run'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:160:in `standard_exception_handling'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:70:in `run'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/bin/ruby_noexec_wrapper:14:in `eval'
/Users/siuying/.rvm/gems/ruby-2.0.0-p0/bin/ruby_noexec_wrapper:14:in `<main>'
Tasks: TOP => default => simulator => build:simulator
(See full trace by running task with --trace)
@alloy
HipByte member
alloy commented Mar 28, 2013

@siuying We've just pushed another fix to CocoaPods: CocoaPods/CocoaPods@a5b8aca. Can you double-check the fix?

@alloy
HipByte member
alloy commented Mar 29, 2013

I have pushed the patches to a branch https://github.com/HipByte/motion-cocoapods/tree/CocoaPods-0.17. I wanted to run the tests, but my out-of-date RubyMotion is incompatible. If someone can run them, please do.

@alloy alloy merged commit 8d83394 into HipByte:master Mar 29, 2013
@alloy
HipByte member
alloy commented Mar 29, 2013

Ok, I have merged the changes and pushed a 1.3.0.rc1 gem. Please re-open if these issues persist.

@fabiopelosin fabiopelosin deleted the fabiopelosin:CocoaPods-0.17 branch Apr 19, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.