New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

audit: Use version pinned by brew while executing rubocop cli #3179

Merged
merged 1 commit into from Sep 20, 2017

Conversation

Projects
None yet
2 participants
@GauthamGoli
Member

GauthamGoli commented Sep 20, 2017

  • Have you followed the guidelines in our Contributing document?
  • Have you checked to ensure there aren't other open Pull Requests for the same change?
  • Have you added an explanation of what your changes do and why you'd like us to include them?
  • Have you written new tests for your changes? Here's an example.
  • Have you successfully run brew tests with your changes locally?

If the user has a newer rubocop version than that of HOMEBREW_RUBOCOP_VERSION , then it leads to unexpected Homebrew/homebrew-core#18324 (comment)

This change ensures that rubocop version intended by brew is executed using an undocumented feature as described here https://stackoverflow.com/questions/4061596/how-can-i-call-an-older-version-of-a-gem-from-the-commandline

cc @ilovezfs

@MikeMcQuaid

This comment has been minimized.

Show comment
Hide comment
@MikeMcQuaid

MikeMcQuaid Sep 20, 2017

Member

Great work here, thanks @GauthamGoli!

Member

MikeMcQuaid commented Sep 20, 2017

Great work here, thanks @GauthamGoli!

@MikeMcQuaid MikeMcQuaid merged commit f343aab into Homebrew:master Sep 20, 2017

1 of 3 checks passed

codecov/patch 50% of diff hit (target 67.11%)
Details
codecov/project 67.09% (-0.02%) compared to b93fa96
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

@Homebrew Homebrew locked and limited conversation to collaborators May 4, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.