This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

Simplify CLT version logic check

  • Loading branch information...
alanthing committed Oct 26, 2014
1 parent e5a34cb commit 64270e4877cb6d0d1f87c9ea6a38e8183cb52c8f
Showing with 6 additions and 7 deletions.
  1. +1 βˆ’2 mod_bonjour.rb
  2. +1 βˆ’1 mod_fastcgi.rb
  3. +1 βˆ’1 mod_fcgid.rb
  4. +1 βˆ’1 mod_python.rb
  5. +1 βˆ’1 mod_security.rb
  6. +1 βˆ’1 mod_wsgi.rb
View
@@ -4,7 +4,6 @@ class ModBonjour < Formula
homepage "http://www.opensource.apple.com/source/apache_mod_bonjour/apache_mod_bonjour-23/"
url "http://www.opensource.apple.com/tarballs/apache_mod_bonjour/apache_mod_bonjour-23.tar.gz"
sha1 "597ad957a6524ba05e03e2679fe622abdb2662f8"
version "2.3"
bottle do
cellar :any
@@ -27,7 +26,7 @@ class ModBonjour < Formula
exit 1
end
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version == :yosemite or MacOS.version == :mavericks)
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version >= :mavericks)
unless system("pkgutil --pkgs | grep -qx com.apple.pkg.CLTools_Executables")
onoe "Command Line Tools required, even if Xcode is installed, on OS X 10.9 or 10.10 and not
using Homebrew httpd22 or httpd24. Resolve by running `xcode-select --install`."
View
@@ -26,7 +26,7 @@ class ModFastcgi < Formula
exit 1
end
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version == :yosemite or MacOS.version == :mavericks)
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version >= :mavericks)
unless system("pkgutil --pkgs | grep -qx com.apple.pkg.CLTools_Executables")
onoe "Command Line Tools required, even if Xcode is installed, on OS X 10.9 or 10.10 and not
using Homebrew httpd22 or httpd24. Resolve by running `xcode-select --install`."
View
@@ -28,7 +28,7 @@ class ModFcgid < Formula
exit 1
end
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version == :yosemite or MacOS.version == :mavericks)
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version >= :mavericks)
unless system("pkgutil --pkgs | grep -qx com.apple.pkg.CLTools_Executables")
onoe "Command Line Tools required, even if Xcode is installed, on OS X 10.9 or 10.10 and not
using Homebrew httpd22 or httpd24. Resolve by running `xcode-select --install`."
View
@@ -28,7 +28,7 @@ class ModPython < Formula
exit 1
end
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version == :yosemite or MacOS.version == :mavericks)
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version >= :mavericks)
unless system("pkgutil --pkgs | grep -qx com.apple.pkg.CLTools_Executables")
onoe "Command Line Tools required, even if Xcode is installed, on OS X 10.9 or 10.10 and not
using Homebrew httpd22 or httpd24. Resolve by running `xcode-select --install`."
View
@@ -35,7 +35,7 @@ class ModSecurity < Formula
exit 1
end
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version == :yosemite or MacOS.version == :mavericks)
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version >= :mavericks)
unless system("pkgutil --pkgs | grep -qx com.apple.pkg.CLTools_Executables")
onoe "Command Line Tools required, even if Xcode is installed, on OS X 10.9 or 10.10 and not
using Homebrew httpd22 or httpd24. Resolve by running `xcode-select --install`."
View
@@ -30,7 +30,7 @@ class ModWsgi < Formula
exit 1
end
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version == :yosemite or MacOS.version == :mavericks)
if (! (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")) and (MacOS.version >= :mavericks)
unless system("pkgutil --pkgs | grep -qx com.apple.pkg.CLTools_Executables")
onoe "Command Line Tools required, even if Xcode is installed, on OS X 10.9 or 10.10 and not
using Homebrew httpd22 or httpd24. Resolve by running `xcode-select --install`."

0 comments on commit 64270e4

Please sign in to comment.