This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

multiple: change "--with-brewed-*" to "--with-homebrew-*" to match ot…

…her taps
  • Loading branch information...
alanthing committed Feb 2, 2015
1 parent 30018c2 commit b987b551e2b0a855ce905842067ef2f3fc100d51
Showing with 84 additions and 84 deletions.
  1. +3 −3 httpd22.rb
  2. +3 −3 httpd24.rb
  3. +11 −11 mod_bonjour.rb
  4. +12 −12 mod_fastcgi.rb
  5. +11 −11 mod_fcgid.rb
  6. +14 −14 mod_python.rb
  7. +16 −16 mod_security.rb
  8. +14 −14 mod_wsgi.rb
View
@@ -9,13 +9,13 @@ class Httpd22 < Formula
skip_clean :la
option "with-brewed-openssl", "Use Homebrew's SSL instead of the system version"
option "with-homebrew-openssl", "Use Homebrew's SSL instead of the system version"
option "with-mpm-worker", "Use the Worker Multi-Processing Module instead of Prefork"
option "with-mpm-event", "Use the Event Multi-Processing Module instead of Prefork"
option "with-privileged-ports", "Use the default ports 80 and 443 (which require root privileges), instead of 8080 and 8443"
depends_on "apr-util"
depends_on "openssl" if build.with? "brewed-openssl"
depends_on "openssl" if build.with? "homebrew-openssl"
depends_on "pcre" => :optional
depends_on "homebrew/dupes/zlib"
@@ -52,7 +52,7 @@ def install
args << "--with-apr-util=#{Formula["apr-util"].opt_prefix}"
args << "--with-z=#{Formula['zlib'].opt_prefix}"
if build.with? "brewed-openssl"
if build.with? "homebrew-openssl"
args << "--with-ssl=#{Formula['openssl'].opt_prefix}"
else
args << "--with-ssl=/usr"
View
@@ -9,13 +9,13 @@ class Httpd24 < Formula
skip_clean :la
option "with-brewed-openssl", "Use Homebrew's SSL instead of the system version"
option "with-homebrew-openssl", "Use Homebrew's SSL instead of the system version"
option "with-mpm-worker", "Use the Worker Multi-Processing Module instead of Prefork"
option "with-mpm-event", "Use the Event Multi-Processing Module instead of Prefork"
option "with-privileged-ports", "Use the default ports 80 and 443 (which require root privileges), instead of 8080 and 8443"
depends_on "apr-util"
depends_on "openssl" if build.with? "brewed-openssl"
depends_on "openssl" if build.with? "homebrew-openssl"
depends_on "pcre"
depends_on "homebrew/dupes/zlib"
@@ -52,7 +52,7 @@ def install
args << "--with-pcre=#{Formula['pcre'].opt_prefix}"
args << "--with-z=#{Formula['zlib'].opt_prefix}"
if build.with? "brewed-openssl"
if build.with? "homebrew-openssl"
args << "--with-ssl=#{Formula['openssl'].opt_prefix}"
else
args << "--with-ssl=/usr"
View
@@ -28,21 +28,21 @@ def message; <<-EOS.undent
sha1 "3269aeccb44d4ca56588d618cece3a475693c6b7" => :yosemite
end
option "with-brewed-httpd22", "Use Homebrew Apache httpd 2.2"
option "with-brewed-httpd24", "Use Homebrew Apache httpd 2.4"
option "with-homebrew-httpd22", "Use Homebrew Apache httpd 2.2"
option "with-homebrew-httpd24", "Use Homebrew Apache httpd 2.4"
depends_on "httpd22" if build.with? "brewed-httpd22"
depends_on "httpd24" if build.with? "brewed-httpd24"
depends_on CLTRequirement if build.without? "brewed-httpd22" and build.without? "brewed-httpd24"
depends_on "httpd22" if build.with? "homebrew-httpd22"
depends_on "httpd24" if build.with? "homebrew-httpd24"
depends_on CLTRequirement if build.without? "homebrew-httpd22" and build.without? "homebrew-httpd24"
def apache_apxs
if build.with? "brewed-httpd22"
if build.with? "homebrew-httpd22"
%W[sbin bin].each do |dir|
if File.exist?(location = "#{Formula['httpd22'].opt_prefix}/#{dir}/apxs")
return location
end
end
elsif build.with? "brewed-httpd24"
elsif build.with? "homebrew-httpd24"
%W[sbin bin].each do |dir|
if File.exist?(location = "#{Formula['httpd24'].opt_prefix}/#{dir}/apxs")
return location
@@ -54,17 +54,17 @@ def apache_apxs
end
def apache_configdir
if build.with? "brewed-httpd22"
if build.with? "homebrew-httpd22"
"#{etc}/apache2/2.2"
elsif build.with? "brewed-httpd24"
elsif build.with? "homebrew-httpd24"
"#{etc}/apache2/2.4"
else
"/etc/apache2"
end
end
def install
if build.with? "brewed-httpd22" and build.with? "brewed-httpd24"
if build.with? "homebrew-httpd22" and build.with? "homebrew-httpd24"
onoe "Cannot build for http22 and httpd24 at the same time"
exit 1
end
@@ -85,7 +85,7 @@ def caveats
RegisterResource "Site Title" / 80
</IfModule>
NOTE: If you're _NOT_ using --with-brewed-httpd22 or --with-brewed-httpd24 and having
NOTE: If you're _NOT_ using --with-homebrew-httpd22 or --with-homebrew-httpd24 and having
installation problems relating to a missing `cc` compiler and `OSX#{MacOS.version}.xctoolchain`,
read the "Troubleshooting" section of https://github.com/Homebrew/homebrew-apache
EOS
View
@@ -27,26 +27,26 @@ def message; <<-EOS.undent
sha1 "1720f7b434e745b8127d99a906eace447b8b9ea0" => :yosemite
end
option "with-brewed-httpd22", "Use Homebrew Apache httpd 2.2"
option "with-brewed-httpd24", "Use Homebrew Apache httpd 2.4"
option "with-homebrew-httpd22", "Use Homebrew Apache httpd 2.2"
option "with-homebrew-httpd24", "Use Homebrew Apache httpd 2.4"
depends_on "httpd22" if build.with? "brewed-httpd22"
depends_on "httpd24" if build.with? "brewed-httpd24"
depends_on CLTRequirement if build.without? "brewed-httpd22" and build.without? "brewed-httpd24"
depends_on "httpd22" if build.with? "homebrew-httpd22"
depends_on "httpd24" if build.with? "homebrew-httpd24"
depends_on CLTRequirement if build.without? "homebrew-httpd22" and build.without? "homebrew-httpd24"
if build.with? "brewed-httpd22" and build.with? "brewed-httpd24"
if build.with? "homebrew-httpd22" and build.with? "homebrew-httpd24"
onoe "Cannot build for http22 and httpd24 at the same time"
exit 1
end
def apache_apxs
if build.with? "brewed-httpd22"
if build.with? "homebrew-httpd22"
%W[sbin bin].each do |dir|
if File.exist?(location = "#{Formula['httpd22'].opt_prefix}/#{dir}/apxs")
return location
end
end
elsif build.with? "brewed-httpd24"
elsif build.with? "homebrew-httpd24"
%W[sbin bin].each do |dir|
if File.exist?(location = "#{Formula['httpd24'].opt_prefix}/#{dir}/apxs")
return location
@@ -58,16 +58,16 @@ def apache_apxs
end
def apache_configdir
if build.with? "brewed-httpd22"
if build.with? "homebrew-httpd22"
"#{etc}/apache2/2.2"
elsif build.with? "brewed-httpd24"
elsif build.with? "homebrew-httpd24"
"#{etc}/apache2/2.4"
else
"/etc/apache2"
end
end
if (MacOS.version == :yosemite or build.with? "brewed-httpd24")
if (MacOS.version == :yosemite or build.with? "homebrew-httpd24")
patch do
url "https://raw.githubusercontent.com/ByteInternet/libapache-mod-fastcgi/byte/debian/patches/byte-compile-against-apache24.diff"
sha1 "1000fac5bf814d716641bbd1528de34449049a73"
@@ -86,7 +86,7 @@ def caveats; <<-EOS.undent
Upon restarting Apache, you should see the following message in the error log:
[notice] FastCGI: process manager initialized
NOTE: If you're _NOT_ using --with-brewed-httpd22 or --with-brewed-httpd24 and having
NOTE: If you're _NOT_ using --with-homebrew-httpd22 or --with-homebrew-httpd24 and having
installation problems relating to a missing `cc` compiler and `OSX#{MacOS.version}.xctoolchain`,
read the "Troubleshooting" section of https://github.com/Homebrew/homebrew-apache
EOS
View
@@ -29,26 +29,26 @@ def message; <<-EOS.undent
sha1 "5cdbd977a60711772bb7decd7b10146ab5b4613f" => :yosemite
end
option "with-brewed-httpd22", "Use Homebrew Apache httpd 2.2"
option "with-brewed-httpd24", "Use Homebrew Apache httpd 2.4"
option "with-homebrew-httpd22", "Use Homebrew Apache httpd 2.2"
option "with-homebrew-httpd24", "Use Homebrew Apache httpd 2.4"
depends_on "httpd22" if build.with? "brewed-httpd22"
depends_on "httpd24" if build.with? "brewed-httpd24"
depends_on CLTRequirement if build.without? "brewed-httpd22" and build.without? "brewed-httpd24"
depends_on "httpd22" if build.with? "homebrew-httpd22"
depends_on "httpd24" if build.with? "homebrew-httpd24"
depends_on CLTRequirement if build.without? "homebrew-httpd22" and build.without? "homebrew-httpd24"
if build.with? "brewed-httpd22" and build.with? "brewed-httpd24"
if build.with? "homebrew-httpd22" and build.with? "homebrew-httpd24"
onoe "Cannot build for http22 and httpd24 at the same time"
exit 1
end
def apache_apxs
if build.with? "brewed-httpd22"
if build.with? "homebrew-httpd22"
%W[sbin bin].each do |dir|
if File.exist?(location = "#{Formula['httpd22'].opt_prefix}/#{dir}/apxs")
return location
end
end
elsif build.with? "brewed-httpd24"
elsif build.with? "homebrew-httpd24"
%W[sbin bin].each do |dir|
if File.exist?(location = "#{Formula['httpd24'].opt_prefix}/#{dir}/apxs")
return location
@@ -60,9 +60,9 @@ def apache_apxs
end
def apache_configdir
if build.with? "brewed-httpd22"
if build.with? "homebrew-httpd22"
"#{etc}/apache2/2.2"
elsif build.with? "brewed-httpd24"
elsif build.with? "homebrew-httpd24"
"#{etc}/apache2/2.4"
else
"/etc/apache2"
@@ -79,7 +79,7 @@ def caveats; <<-EOS.undent
You must manually edit #{apache_configdir}/httpd.conf to include
LoadModule fcgid_module #{libexec}/mod_fcgid.so
NOTE: If you're _NOT_ using --with-brewed-httpd22 or --with-brewed-httpd24 and having
NOTE: If you're _NOT_ using --with-homebrew-httpd22 or --with-homebrew-httpd24 and having
installation problems relating to a missing `cc` compiler and `OSX#{MacOS.version}.xctoolchain`,
read the "Troubleshooting" section of https://github.com/Homebrew/homebrew-apache
EOS
View
@@ -27,28 +27,28 @@ def message; <<-EOS.undent
sha1 "0316f2ab4c1606e835ec4063949bcdbf7904e7a0" => :yosemite
end
option "with-brewed-httpd22", "Use Homebrew Apache httpd 2.2"
option "with-brewed-httpd24", "Use Homebrew Apache httpd 2.4"
option "with-brewed-python", "Use Homebrew python"
option "with-homebrew-httpd22", "Use Homebrew Apache httpd 2.2"
option "with-homebrew-httpd24", "Use Homebrew Apache httpd 2.4"
option "with-homebrew-python", "Use Homebrew python"
depends_on "httpd22" if build.with? "brewed-httpd22"
depends_on "httpd24" if build.with? "brewed-httpd24"
depends_on "python" if build.with? "brewed-python"
depends_on CLTRequirement if build.without? "brewed-httpd22" and build.without? "brewed-httpd24"
depends_on "httpd22" if build.with? "homebrew-httpd22"
depends_on "httpd24" if build.with? "homebrew-httpd24"
depends_on "python" if build.with? "homebrew-python"
depends_on CLTRequirement if build.without? "homebrew-httpd22" and build.without? "homebrew-httpd24"
if build.with? "brewed-httpd22" and build.with? "brewed-httpd24"
if build.with? "homebrew-httpd22" and build.with? "homebrew-httpd24"
onoe "Cannot build for http22 and httpd24 at the same time"
exit 1
end
def apache_apxs
if build.with? "brewed-httpd22"
if build.with? "homebrew-httpd22"
%W[sbin bin].each do |dir|
if File.exist?(location = "#{Formula['httpd22'].opt_prefix}/#{dir}/apxs")
return location
end
end
elsif build.with? "brewed-httpd24"
elsif build.with? "homebrew-httpd24"
%W[sbin bin].each do |dir|
if File.exist?(location = "#{Formula['httpd24'].opt_prefix}/#{dir}/apxs")
return location
@@ -60,9 +60,9 @@ def apache_apxs
end
def apache_configdir
if build.with? "brewed-httpd22"
if build.with? "homebrew-httpd22"
"#{etc}/apache2/2.2"
elsif build.with? "brewed-httpd24"
elsif build.with? "homebrew-httpd24"
"#{etc}/apache2/2.4"
else
"/etc/apache2"
@@ -72,7 +72,7 @@ def apache_configdir
def install
args = "--prefix=#{prefix}"
args << "--with-apxs=#{apache_apxs}"
args << "--with-python=#{HOMEBREW_PREFIX}/bin/python" if build.with? "brewed-python"
args << "--with-python=#{HOMEBREW_PREFIX}/bin/python" if build.with? "homebrew-python"
system "./configure", *args
system "make"
@@ -84,7 +84,7 @@ def caveats; <<-EOS.undent
You must manually edit #{apache_configdir}/httpd.conf to include
LoadModule python_module #{libexec}/mod_python.so
NOTE: If you're _NOT_ using --with-brewed-httpd22 or --with-brewed-httpd24 and having
NOTE: If you're _NOT_ using --with-homebrew-httpd22 or --with-homebrew-httpd24 and having
installation problems relating to a missing `cc` compiler and `OSX#{MacOS.version}.xctoolchain`,
read the "Troubleshooting" section of https://github.com/Homebrew/homebrew-apache
EOS
View
@@ -26,36 +26,36 @@ def message; <<-EOS.undent
sha1 "a2cb16d784978092be059f65f4e1d14c09c71009" => :yosemite
end
option "with-brewed-apr", "Use Homebrew apr"
option "with-brewed-httpd22", "Use Homebrew Apache httpd 2.2"
option "with-brewed-httpd24", "Use Homebrew Apache httpd 2.4"
option "with-homebrew-apr", "Use Homebrew apr"
option "with-homebrew-httpd22", "Use Homebrew Apache httpd 2.2"
option "with-homebrew-httpd24", "Use Homebrew Apache httpd 2.4"
depends_on "autoconf" => :build
depends_on "automake" => :build
depends_on "apr-util" if build.with? "brewed-apr"
depends_on "httpd22" if build.with? "brewed-httpd22"
depends_on "httpd24" if build.with? "brewed-httpd24"
depends_on "apr-util" if build.with? "homebrew-apr"
depends_on "httpd22" if build.with? "homebrew-httpd22"
depends_on "httpd24" if build.with? "homebrew-httpd24"
depends_on "libtool" => :build
depends_on "pcre"
depends_on CLTRequirement if build.without? "brewed-httpd22" and build.without? "brewed-httpd24"
depends_on CLTRequirement if build.without? "homebrew-httpd22" and build.without? "homebrew-httpd24"
if build.with? "brewed-apr" and (build.with? "brewed-httpd22" or build.with? "brewed-httpd24")
opoo "Ignoring --with-brewed-apr: homebrew apr included in httpd22 and httpd24"
if build.with? "homebrew-apr" and (build.with? "homebrew-httpd22" or build.with? "homebrew-httpd24")
opoo "Ignoring --with-homebrew-apr: homebrew apr included in httpd22 and httpd24"
end
if build.with? "brewed-httpd22" and build.with? "brewed-httpd24"
if build.with? "homebrew-httpd22" and build.with? "homebrew-httpd24"
onoe "Cannot build for http22 and httpd24 at the same time"
exit 1
end
def apache_apxs
if build.with? "brewed-httpd22"
if build.with? "homebrew-httpd22"
%W[sbin bin].each do |dir|
if File.exist?(location = "#{Formula['httpd22'].opt_prefix}/#{dir}/apxs")
return location
end
end
elsif build.with? "brewed-httpd24"
elsif build.with? "homebrew-httpd24"
%W[sbin bin].each do |dir|
if File.exist?(location = "#{Formula['httpd24'].opt_prefix}/#{dir}/apxs")
return location
@@ -67,9 +67,9 @@ def apache_apxs
end
def apache_configdir
if build.with? "brewed-httpd22"
if build.with? "homebrew-httpd22"
"#{etc}/apache2/2.2"
elsif build.with? "brewed-httpd24"
elsif build.with? "homebrew-httpd24"
"#{etc}/apache2/2.4"
else
"/etc/apache2"
@@ -81,7 +81,7 @@ def install
args << "--with-pcre=#{Formula['pcre'].opt_prefix}"
args << "--with-apxs=#{apache_apxs}"
if (build.with? "brewed-httpd22") || (build.with? "brewed-httpd24") || (build.with? "brewed-apr")
if (build.with? "homebrew-httpd22") || (build.with? "homebrew-httpd24") || (build.with? "homebrew-apr")
args << "--with-apr=#{Formula['apr'].opt_prefix}"
args << "--with-apu=#{Formula['apr-util'].prefix}/bin"
else
@@ -114,7 +114,7 @@ def caveats; <<-EOS.undent
Sample configuration file for Apache is at:
#{prefix}/modsecurity.conf-recommended
NOTE: If you're _NOT_ using --with-brewed-httpd22 or --with-brewed-httpd24 and having
NOTE: If you're _NOT_ using --with-homebrew-httpd22 or --with-homebrew-httpd24 and having
installation problems relating to a missing `cc` compiler and `OSX#{MacOS.version}.xctoolchain`,
read the "Troubleshooting" section of https://github.com/Homebrew/homebrew-apache
EOS
Oops, something went wrong.

0 comments on commit b987b55

Please sign in to comment.