This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

Fix dependency references

Remove homebrew-dupes and homebrew-apache references to
homebrew-apache formulae.
  • Loading branch information...
Noctem authored and alanthing committed Sep 26, 2014
1 parent c90ba7c commit f3cf5488fdba83d712f7323506b16bf2bbc82ca6
Showing with 9 additions and 9 deletions.
  1. +3 βˆ’3 ab.rb
  2. +1 βˆ’1 apr-util.rb
  3. +2 βˆ’2 httpd22.rb
  4. +2 βˆ’2 httpd24.rb
  5. +1 βˆ’1 mod_security.rb
View
6 ab.rb
@@ -8,7 +8,7 @@ class Ab < Formula
keg_only :provided_by_osx
conflicts_with "httpd22", "httpd24", :because => "both install `ab`"
depends_on "homebrew/apache/apr-util"
depends_on "apr-util"
depends_on "libtool" => :build
option "with-ssl-patch", 'Apply patch for: Bug 49382 - ab says "SSL read failed"'
@@ -30,8 +30,8 @@ def install
ENV["LTFLAGS"] = "--tag CC"
system "./configure", "--prefix=#{prefix}", "--disable-debug",
"--disable-dependency-tracking",
"--with-apr=#{Formula["homebrew/dupes/apr"].opt_prefix}",
"--with-apr-util=#{Formula["homebrew/dupes/apr-util"].opt_prefix}"
"--with-apr=#{Formula["apr"].opt_prefix}",
"--with-apr-util=#{Formula["apr-util"].opt_prefix}"
cd "support" do
system "make", "ab"
View
@@ -7,7 +7,7 @@ class AprUtil < Formula
keg_only :provided_by_osx
depends_on "homebrew/apache/apr"
depends_on "apr"
depends_on "mysql-connector-c" => :optional
def install
View
@@ -16,8 +16,8 @@ class Httpd22 < Formula
option "with-privileged-ports", "Use the default ports 80 and 443 (which require root privileges), instead of 8080 and 8443"
if build.with? "brewed-apr"
depends_on "homebrew/dupes/apr"
depends_on "homebrew/dupes/apr-util"
depends_on "apr"
depends_on "apr-util"
end
depends_on "pcre" => :optional
View
@@ -16,8 +16,8 @@ class Httpd24 < Formula
option "with-privileged-ports", "Use the default ports 80 and 443 (which require root privileges), instead of 8080 and 8443"
if build.with? "brewed-apr"
depends_on "homebrew/dupes/apr"
depends_on "homebrew/dupes/apr-util"
depends_on "apr"
depends_on "apr-util"
end
depends_on "pcre"
View
@@ -11,7 +11,7 @@ class ModSecurity < Formula
option 'with-brewed-httpd22', 'Use Homebrew Apache httpd 2.2'
option 'with-brewed-httpd24', 'Use Homebrew Apache httpd 2.4'
depends_on 'homebrew/dupes/apr' if build.with? 'brewed-apr'
depends_on 'apr' if build.with? 'brewed-apr'
depends_on 'httpd22' if build.with? 'brewed-httpd22'
depends_on 'httpd24' if build.with? 'brewed-httpd24'

0 comments on commit f3cf548

Please sign in to comment.