🔢 Alternate versions of Casks
Ruby Shell
commitay Update powershell-preview to 6.1.0-preview.4 (#5985)
* Update powershell-preview to 6.1.0-preview.4

* Update powershell-preview.rb
Latest commit 6969d0b Jul 21, 2018

README.md

homebrew-cask-versions

Here you'll find alternate versions of Casks for the homebrew-cask project.

Usage

After you install homebrew-cask, run the following command:

$ brew tap homebrew/cask-versions

You can now install alternate versions of Casks.

$ brew cask install iterm2-beta

Acceptable Casks

homebrew/cask-versions is not intended to be used for all and any old versions you personally require for xyz project; casks submitted here should be expected to be used by a reasonable number of people and supported by contributors long-term.

You may wish to consider hosting your own tap for casks you wish to personally support that do not meet the above standards.

For this repo, rules are (following our nomenclature):

  • Include the latest minor version of legacy versions of commercial and freemium software.
  • Legacy versions of commercial and freemium software are restricted to a maximum of five casks.
  • Include beta, development, unstable, nightly, early access program, ….
  • Refuse legacy versions of gratis or open-source software, unless there is a clear demonstrable need for them.
  • Legacy versions of gratis or open-source software that were accepted should be removed after one year.
  • Include casks that do not fit the rules, but need to exist somewhere since they are required by other casks.

License

Code is under the BSD 2 Clause (NetBSD) license