Permalink
Browse files

pandoc-citeproc: GHC 8 compatibility

Without adding "allow-newer" for the packages base, data-default, and
time, I get build failures like the following (depends which subset
you're trying) when using GHC 8:

```
cabal: Could not resolve dependencies:
trying: pandoc-citeproc-0.9.1.1 (user goal)
trying: data-default-0.7.0 (dependency of pandoc-citeproc-0.9.1.1)
trying: aeson-0.11.2.0 (dependency of pandoc-citeproc-0.9.1.1)
next goal: pandoc (dependency of pandoc-citeproc-0.9.1.1)
rejecting: pandoc-1.17.0.3 (conflict: data-default==0.7.0, pandoc =>
data-default>=0.4 && <0.7)
etc. etc.
```

Can be removed as soon as pandoc-citeproc and its dependencies lift the
unnecessary caps, or until pandoc-citeproc itself has a built-in
workaround.

Closes #1452.

Signed-off-by: ilovezfs <ilovezfs@icloud.com>
  • Loading branch information...
ilovezfs committed May 26, 2016
1 parent 6ffcaa6 commit 422b6bd3d8a3984b77685898b9e393e320c4e904
Showing with 5 additions and 0 deletions.
  1. +5 −0 Formula/pandoc-citeproc.rb
@@ -19,6 +19,11 @@ class PandocCiteproc < Formula
depends_on "pandoc"
def install
# GHC 8 compat
# Fixes "cabal: Could not resolve dependencies"
# Reported 26 May 2016: https://github.com/jgm/pandoc-citeproc/issues/235
(buildpath/"cabal.config").write("allow-newer: base,data-default,time\n")
args = []
args << "--constraint=cryptonite -support_aesni" if MacOS.version <= :lion
install_cabal_package *args

0 comments on commit 422b6bd

Please sign in to comment.