Permalink
Browse files

maven@3.3: make the test Java 9 compatible

JDK 9 dropped support of source and target 1.5, however they
are the default for maven. This commit changes this.

Also it removes the warning about file encoding.

Closes #19869.

Signed-off-by: ilovezfs <ilovezfs@icloud.com>
  • Loading branch information...
bric3 authored and ilovezfs committed Oct 26, 2017
1 parent b325043 commit 5395f7b236223e1146a55f24e2ac368f7ebd739b
Showing with 5 additions and 0 deletions.
  1. +5 −0 Formula/maven@3.3.rb
@@ -37,6 +37,11 @@ def install
<groupId>org.homebrew</groupId> <groupId>org.homebrew</groupId>
<artifactId>maven-test</artifactId> <artifactId>maven-test</artifactId>
<version>1.0.0-SNAPSHOT</version> <version>1.0.0-SNAPSHOT</version>
<properties>
<maven.compiler.source>1.8</maven.compiler.source>
<maven.compiler.target>1.8</maven.compiler.target>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
</properties>
</project> </project>
EOS EOS
(testpath/"src/main/java/org/homebrew/MavenTest.java").write <<~EOS (testpath/"src/main/java/org/homebrew/MavenTest.java").write <<~EOS

0 comments on commit 5395f7b

Please sign in to comment.