Permalink
Browse files

qt: add optional postgresql support.

Closes Homebrew/legacy-homebrew#32397.

Signed-off-by: Mike McQuaid <mike@mikemcquaid.com>
  • Loading branch information...
NicoIGN authored and MikeMcQuaid committed Sep 18, 2014
1 parent 238f87f commit 5be2f05a4311ec376c4f5790dbc3fafb5ddfd2d8
Showing with 2 additions and 0 deletions.
  1. +2 −0 Formula/qt.rb
View
@@ -32,6 +32,7 @@ class Qt < Formula
depends_on "d-bus" => :optional
depends_on "mysql" => :optional
depends_on "postgresql" => :optional
def install
ENV.universal_binary if build.universal?
@@ -54,6 +55,7 @@ def install
end
args << "-plugin-sql-mysql" if build.with? 'mysql'
args << "-plugin-sql-psql" if build.with? 'postgresql'
if build.with? 'd-bus'
dbus_opt = Formula["d-bus"].opt_prefix

0 comments on commit 5be2f05

Please sign in to comment.