Permalink
Browse files

Replace == :leopard with <= :leopard

  • Loading branch information...
mistydemeo committed Jul 10, 2013
1 parent c752d03 commit f7a044271ec5596f041a3f6bcaab5ac0c3c431a2
View
@@ -12,7 +12,7 @@ class Aria2 < Formula
depends_on 'curl-ca-bundle' => :recommended
# Leopard's libxml2 is too old.
depends_on 'libxml2' if MacOS.version == :leopard
depends_on 'libxml2' if MacOS.version <= :leopard
def install
args = %W[--disable-dependency-tracking --prefix=#{prefix}]
View
@@ -62,7 +62,7 @@ def install
# For 32-bit compilation under gcc 4.2, see:
# http://trac.macports.org/ticket/20938#comment:22
if MacOS.version == :leopard or Hardware.is_32_bit?
if MacOS.version <= :leopard or Hardware.is_32_bit?
inreplace 'cmake/admFFmpegBuild.cmake',
'${CMAKE_INSTALL_PREFIX})',
'${CMAKE_INSTALL_PREFIX} --extra-cflags=-mdynamic-no-pic)'
View
@@ -6,7 +6,7 @@ class Bind < Formula
sha1 '9e1a9e5e45685befce6b93d4fcfd63e50eaeb2cf'
version '9.9.3-P1'
depends_on "openssl" if MacOS.version == :leopard
depends_on "openssl" if MacOS.version <= :leopard
def install
ENV.libxml2
@@ -23,7 +23,7 @@ def install
# For Xcode-only systems we help a bit to find openssl.
# If CLT.installed?, it evaluates to "/usr", which works.
args << "--with-openssl=#{MacOS.sdk_path}/usr" unless MacOS.version == :leopard
args << "--with-openssl=#{MacOS.sdk_path}/usr" unless MacOS.version <= :leopard
system "./configure", *args
View
@@ -45,7 +45,7 @@ def install
args << '--enable-gobject=no'
end
args << '--enable-xcb=no' if MacOS.version == :leopard
args << '--enable-xcb=no' if MacOS.version <= :leopard
system "./configure", *args
system "make install"
View
@@ -30,7 +30,7 @@ def install
--localstatedir=#{var}
--with-python=#{python}]
args << "--disable-embedded-perl" if MacOS.version == :leopard
args << "--disable-embedded-perl" if MacOS.version <= :leopard
args << "--disable-java" unless build.include? "java"
args << "--enable-debug" if build.include? "debug"
View
@@ -19,7 +19,7 @@ class Couchdb < Formula
depends_on 'spidermonkey'
depends_on 'icu4c'
depends_on 'erlang'
depends_on 'curl' if MacOS.version == :leopard
depends_on 'curl' if MacOS.version <= :leopard
def install
# couchdb 1.3.0 supports vendor names and versioning
View
@@ -9,7 +9,7 @@ class Disco < Formula
depends_on :python
depends_on 'erlang'
depends_on 'simplejson' => :python if MacOS.version == :leopard
depends_on 'simplejson' => :python if MacOS.version <= :leopard
depends_on 'libcmph'
def patches
View
@@ -5,7 +5,7 @@ class Ejabberd < Formula
url "http://www.process-one.net/downloads/ejabberd/2.1.13/ejabberd-2.1.13.tgz"
sha1 '6343186be2e84824d2da32e36110b72d6673730e'
depends_on "openssl" if MacOS.version == :leopard
depends_on "openssl" if MacOS.version <= :leopard
depends_on "erlang"
option "32-bit"
@@ -28,7 +28,7 @@ def install
"--sysconfdir=#{etc}",
"--localstatedir=#{var}"]
if MacOS.version == :leopard
if MacOS.version <= :leopard
openssl = Formula.factory('openssl')
args << "--with-openssl=#{openssl.prefix}"
end
View
@@ -68,7 +68,7 @@ def install
"--enable-shared-zlib",
"--enable-smp-support"]
args << "--with-dynamic-trace=dtrace" unless MacOS.version == :leopard or not MacOS::CLT.installed?
args << "--with-dynamic-trace=dtrace" unless MacOS.version <= :leopard or not MacOS::CLT.installed?
unless build.include? 'disable-hipe'
# HIPE doesn't strike me as that reliable on OS X
@@ -50,7 +50,7 @@ def install
"--prefix=#{prefix}",
"--enable-shared", "--disable-static"]
args << "--without-magick-plus-plus" if build.include? 'without-magick-plus-plus'
args << "--disable-openmp" if MacOS.version == :leopard or not ENV.compiler == :gcc # libgomp unavailable
args << "--disable-openmp" if MacOS.version <= :leopard or not ENV.compiler == :gcc # libgomp unavailable
args << "--with-gslib" if build.include? 'with-ghostscript'
args << "--with-gs-font-dir=#{HOMEBREW_PREFIX}/share/ghostscript/fonts" \
unless ghostscript_fonts?
View
@@ -20,7 +20,7 @@ class Grass < Formula
depends_on 'wxmac' => :recommended # prefer over OS X's version because of 64bit
depends_on :postgresql => :optional
depends_on :mysql => :optional
depends_on "cairo" if MacOS.version == :leopard
depends_on "cairo" if MacOS.version <= :leopard
depends_on :x11 # needs to find at least X11/include/GL/gl.h
# Patches that files are not installed outside of the prefix.
@@ -83,7 +83,7 @@ def install
end
# Deal with Cairo support
if MacOS.version == :leopard
if MacOS.version <= :leopard
cairo = Formula.factory('cairo')
args << "--with-cairo-includes=#{cairo.include}/cairo"
args << "--with-cairo-libs=#{cairo.lib}"
View
@@ -22,7 +22,8 @@ def patches
def install
# Bus error
ENV.no_optimization if MacOS.version == :leopard
# TODO what are the more specific circumstances?
ENV.no_optimization if MacOS.version <= :leopard
system "./configure", "--disable-dependency-tracking",
"--prefix=#{prefix}"
View
@@ -8,7 +8,7 @@ class Libmemcached < Formula
depends_on 'memcached'
def install
ENV.append_to_cflags "-undefined dynamic_lookup" if MacOS.version == :leopard
ENV.append_to_cflags "-undefined dynamic_lookup" if MacOS.version <= :leopard
system "./configure", "--prefix=#{prefix}"
system "make install"
View
@@ -10,7 +10,7 @@ class Libmms < Formula
def patches
# see https://trac.macports.org/ticket/27988
if MacOS.version == :leopard
if MacOS.version <= :leopard
{ :p0 => "https://trac.macports.org/export/87883/trunk/dports/multimedia/libmms/files/src_mms-common.h.patch" }
end
end
View
@@ -13,7 +13,7 @@ class Libvirt < Formula
depends_on 'yajl'
depends_on :python => :recommended
if MacOS.version == :leopard
if MacOS.version <= :leopard
# Definitely needed on Leopard, but not on Snow Leopard.
depends_on "readline"
depends_on "libxml2"
View
@@ -8,7 +8,7 @@ class Libxmlxx < Formula
depends_on 'pkg-config' => :build
depends_on 'glibmm'
# LibXML++ can't compile agains the version of LibXML shipped with Leopard
depends_on 'libxml2' if MacOS.version == :leopard
depends_on 'libxml2' if MacOS.version <= :leopard
def install
system "./configure", "--disable-dependency-tracking",
View
@@ -63,7 +63,7 @@ def install
]
args << '--disable-mad'
args << '--disable-curl' if MacOS.version == :leopard
args << '--disable-curl' if MacOS.version <= :leopard
args << "--with-faad=#{Formula.factory('faad2').opt_prefix}"
args << '--enable-zzip' if build.with? 'libzzip'
View
@@ -8,7 +8,7 @@ class Nmap < Formula
head 'https://guest:@svn.nmap.org/nmap/', :using => :svn
# Leopard's version of OpenSSL isn't new enough
depends_on "openssl" if MacOS.version == :leopard
depends_on "openssl" if MacOS.version <= :leopard
fails_with :llvm do
build 2334
@@ -23,7 +23,7 @@ def install
--without-zenmap
--disable-universal]
if MacOS.version == :leopard
if MacOS.version <= :leopard
openssl = Formula.factory('openssl')
args << "--with-openssl=#{openssl.prefix}"
end
View
@@ -10,7 +10,7 @@ def install
cd "mozilla/nsprpub" do
# Fixes a bug with linking against CoreFoundation, needed to work with SpiderMonkey
# See: http://openradar.appspot.com/7209349
target_frameworks = (Hardware.is_32_bit? or MacOS.version == :leopard) ? "-framework Carbon" : ""
target_frameworks = (Hardware.is_32_bit? or MacOS.version <= :leopard) ? "-framework Carbon" : ""
inreplace "pr/src/Makefile.in", "-framework CoreServices -framework CoreFoundation", target_frameworks
args = %W[
View
@@ -8,7 +8,7 @@ class PostgresXc < Formula
depends_on :arch => :x86_64
depends_on :python => :recommended
depends_on 'readline'
depends_on 'libxml2' if MacOS.version == :leopard # Leopard libxml is too old
depends_on 'libxml2' if MacOS.version <= :leopard # Leopard libxml is too old
depends_on 'ossp-uuid' => :recommended
conflicts_with 'postgresql',
View
@@ -6,7 +6,7 @@ class Postgresql < Formula
sha1 '75b53c884cb10ed9404747b51677358f12082152'
depends_on 'readline'
depends_on 'libxml2' if MacOS.version == :leopard # Leopard libxml is too old
depends_on 'libxml2' if MacOS.version <= :leopard # Leopard libxml is too old
depends_on 'ossp-uuid' => :recommended
depends_on :python => :recommended
View
@@ -25,12 +25,12 @@ class Qt < Formula
depends_on "d-bus" if build.with? 'qtdbus'
depends_on "mysql" => :optional
depends_on 'sqlite' if MacOS.version == :leopard
depends_on 'sqlite' if MacOS.version <= :leopard
def patches
# Fixes compilation failure on Leopard.
# https://bugreports.qt-project.org/browse/QTBUG-23258
if MacOS.version == :leopard
if MacOS.version <= :leopard
"http://bugreports.qt-project.org/secure/attachment/26712/Patch-Qt-4.8-for-10.5"
end
end
@@ -64,7 +64,7 @@ def install
args << "-platform" << "unsupported/macx-clang" if ENV.compiler == :clang
# See: https://github.com/mxcl/homebrew/issues/issue/744
args << "-system-sqlite" if MacOS.version == :leopard
args << "-system-sqlite" if MacOS.version <= :leopard
args << "-plugin-sql-mysql" if build.with? 'mysql'
View
@@ -18,7 +18,7 @@ class RabbitmqC < Formula
depends_on :automake
depends_on :libtool
depends_on 'rabbitmq'
depends_on 'simplejson' => :python if MacOS.version == :leopard
depends_on 'simplejson' => :python if MacOS.version <= :leopard
def install
ENV.universal_binary if build.universal?
View
@@ -5,7 +5,7 @@ class Rabbitmq < Formula
url 'http://www.rabbitmq.com/releases/rabbitmq-server/v3.1.3/rabbitmq-server-mac-standalone-3.1.3.tar.gz'
sha1 '631b9e46e046db9f591d6027ee690ffaaab20a45'
depends_on 'simplejson' => :python if MacOS.version == :leopard
depends_on 'simplejson' => :python if MacOS.version <= :leopard
def install
# Install the base files
View
@@ -14,7 +14,7 @@ def copy_libtool_files!
s = Formula.factory('libtool').share
d = "#{s}/libtool/config"
cp ["#{d}/config.guess", "#{d}/config.sub"], "."
elsif MacOS.version == :leopard
elsif MacOS.version <= :leopard
cp Dir["#{MacOS::Xcode.prefix}/usr/share/libtool/config.*"], "."
else
cp Dir["#{MacOS::Xcode.prefix}/usr/share/libtool/config/config.*"], "."
View
@@ -7,7 +7,7 @@ class Rtmpdump < Formula
head 'git://git.ffmpeg.org/rtmpdump'
depends_on 'openssl' if MacOS.version == :leopard
depends_on 'openssl' if MacOS.version <= :leopard
fails_with :llvm do
build '2336'
View
@@ -13,7 +13,7 @@ class Rtorrent < Formula
def install
args = ["--disable-debug", "--disable-dependency-tracking", "--prefix=#{prefix}"]
args << "--with-xmlrpc-c" if build.with? "xmlrpc-c"
if MacOS.version == :leopard
if MacOS.version <= :leopard
inreplace 'configure' do |s|
s.gsub! ' pkg_cv_libcurl_LIBS=`$PKG_CONFIG --libs "libcurl >= 7.15.4" 2>/dev/null`',
' pkg_cv_libcurl_LIBS=`$PKG_CONFIG --libs "libcurl >= 7.15.4" | sed -e "s/-arch [^-]*/-arch $(uname -m) /" 2>/dev/null`'
View
@@ -14,7 +14,7 @@ class Spidermonkey < Formula
def install
# aparently this flag causes the build to fail for ivanvc on 10.5 with a
# penryn (core 2 duo) CPU. So lets be cautious here and remove it.
ENV['CFLAGS'] = ENV['CFLAGS'].gsub(/-msse[^\s]+/, '') if MacOS.version == :leopard
ENV['CFLAGS'] = ENV['CFLAGS'].gsub(/-msse[^\s]+/, '') if MacOS.version <= :leopard
cd "js/src" do
# Remove the broken *(for anyone but FF) install_name
View
@@ -8,7 +8,7 @@ class Stormfs < Formula
depends_on 'pkg-config' => :build
depends_on 'glib'
depends_on 'fuse4x'
depends_on 'curl' if MacOS.version == :leopard
depends_on 'curl' if MacOS.version <= :leopard
def install
system "./configure", "--disable-debug", "--disable-dependency-tracking",
View
@@ -131,7 +131,7 @@ def install
# Remove hard-coded ppc target, add appropriate ones
if build.universal?
arches = "-arch x86_64 -arch i386"
elsif MacOS.version == :leopard
elsif MacOS.version <= :leopard
arches = "-arch i386"
else
arches = "-arch x86_64"
View
@@ -26,7 +26,7 @@ class SwiProlog < Formula
end
# 10.5 versions of these are too old
if MacOS.version == :leopard
if MacOS.version <= :leopard
depends_on 'fontconfig'
depends_on 'expat'
end
View
@@ -14,7 +14,7 @@ def copy_libtool_files!
s = Formula.factory('libtool').share
d = "#{s}/libtool/config"
cp ["#{d}/config.guess", "#{d}/config.sub"], "."
elsif MacOS.version == :leopard
elsif MacOS.version <= :leopard
cp Dir["#{MacOS::Xcode.prefix}/usr/share/libtool/config.*"], "."
else
cp Dir["#{MacOS::Xcode.prefix}/usr/share/libtool/config/config.*"], "."
View
@@ -20,7 +20,7 @@ def copy_libtool_files!
s = Formula.factory('libtool').share
d = "#{s}/libtool/config"
cp ["#{d}/config.guess", "#{d}/config.sub"], "."
elsif MacOS.version == :leopard
elsif MacOS.version <= :leopard
cp Dir["#{MacOS::Xcode.prefix}/usr/share/libtool/config.*"], "."
else
cp Dir["#{MacOS::Xcode.prefix}/usr/share/libtool/config/config.*"], "."
View
@@ -14,7 +14,7 @@ class Wget < Formula
option "enable-iri", "Enable iri support"
option "enable-debug", "Build with debug support"
depends_on "openssl" if MacOS.version == :leopard
depends_on "openssl" if MacOS.version <= :leopard
depends_on "libidn" if build.include? "enable-iri"
if build.head?
View
@@ -106,7 +106,7 @@ def install
--with-x
--x-include=#{MacOS::X11.include}
--x-lib=#{MacOS::X11.lib}]
args << "--disable-win16" if MacOS.version == :leopard or ENV.compiler == :clang
args << "--disable-win16" if MacOS.version <= :leopard or ENV.compiler == :clang
# 64-bit builds of mpg123 are incompatible with 32-bit builds of Wine
args << "--without-mpg123" if Hardware.is_64_bit?

0 comments on commit f7a0442

Please sign in to comment.