This repository has been archived by the owner. It is now read-only.

Fix/workaround for segfault on 10.10 #1311

Closed
ahmedammar opened this Issue Aug 22, 2014 · 4 comments

Comments

5 participants
@ahmedammar

ahmedammar commented Aug 22, 2014

https://gist.github.com/ahmedammar/1651f9e62f1556cfcf5b

I was getting a segfault during compilation, specifically when any of the php binaries were being used (post-linking). The segfault was coming from some openssl calls but it wasn't from openssl.c as that was correctly being linked against homebrew's openssl. The backtrace showed that the SNMP library was the frame right before the crash. Since I don't need SNMP support, I added the changes to abstract-php.rb and recompiled. And voila, functional php builds ...

I brewed with:
brew install -v --debug php55 --with-thread-safety --with-homebrew-openssl --with-homebrew-libxlst --without-snmp

ablyler added a commit that referenced this issue Aug 31, 2014

@ablyler

This comment has been minimized.

Show comment
Hide comment
@ablyler

ablyler Aug 31, 2014

Contributor

Thanks @ahmedammar, I've pushed a commit to address this.

Contributor

ablyler commented Aug 31, 2014

Thanks @ahmedammar, I've pushed a commit to address this.

@ablyler ablyler closed this Aug 31, 2014

ablyler added a commit that referenced this issue Aug 31, 2014

oknoway added a commit to oknoway/homebrew-php that referenced this issue Sep 19, 2014

oknoway added a commit to oknoway/homebrew-php that referenced this issue Sep 19, 2014

@RSully

This comment has been minimized.

Show comment
Hide comment
@RSully

RSully Oct 18, 2014

Contributor

Is there any way to get SNMP and thread safety and homebrew openssl?

Contributor

RSully commented Oct 18, 2014

Is there any way to get SNMP and thread safety and homebrew openssl?

@indeyets

This comment has been minimized.

Show comment
Hide comment
@indeyets
Contributor

indeyets commented Oct 20, 2014

@loren138

This comment has been minimized.

Show comment
Hide comment
@loren138

loren138 Oct 23, 2014

Contributor

Looks like you may want to force a number of other items to use this @ablyler
See #1326 (comment)
and #1326 (comment)

For --with-mssql and --with-fpm

Contributor

loren138 commented Oct 23, 2014

Looks like you may want to force a number of other items to use this @ablyler
See #1326 (comment)
and #1326 (comment)

For --with-mssql and --with-fpm

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.