Skip to content
Browse files

Clean up MacOS version method usage

Signed-off-by: Jack Nagel <jacknagel@gmail.com>
  • Loading branch information...
1 parent 860993d commit cb1326477db36e8fbf7e06e9db6cf1dffe799f5f @jacknagel jacknagel committed Sep 6, 2012
Showing with 11 additions and 11 deletions.
  1. +1 −1 erlang-r14.rb
  2. +1 −1 imagemagick-ruby186.rb
  3. +1 −1 node06.rb
  4. +1 −1 node4.rb
  5. +2 −2 postgresql9.rb
  6. +1 −1 spidermonkey180.rb
  7. +4 −4 subversion16.rb
View
2 erlang-r14.rb
@@ -73,7 +73,7 @@ def install
end
system "./configure", *args
- system "touch lib/wx/SKIP" if MacOS.snow_leopard?
+ touch "lib/wx/SKIP" if MacOS.version >= :snow_leopard
system "make"
system "make install"
View
2 imagemagick-ruby186.rb
@@ -45,7 +45,7 @@ def configure_args
"--with-modules",
"--without-magick-plus-plus"]
- args << "--disable-openmp" if MACOS_VERSION < 10.6 # libgomp unavailable
+ args << "--disable-openmp" if MacOS.version < 10.6 # libgomp unavailable
args << '--without-ghostscript' \
<< "--with-gs-font-dir=#{HOMEBREW_PREFIX}/share/ghostscript/fonts" \
unless ghostscript_srsly?
View
2 node06.rb
@@ -8,7 +8,7 @@ class Node06 < Formula
head 'https://github.com/joyent/node.git'
# Leopard OpenSSL is not new enough, so use our keg-only one
- depends_on 'openssl' if MacOS.leopard?
+ depends_on 'openssl' if MacOS.version == :leopard
fails_with :llvm do
build 2326
View
2 node4.rb
@@ -8,7 +8,7 @@ class Node4 < Formula
head 'https://github.com/joyent/node.git'
# Leopard OpenSSL is not new enough, so use our keg-only one
- depends_on 'openssl' if MacOS.leopard?
+ depends_on 'openssl' if MacOS.version == :leopard
fails_with_llvm :build => 2326
View
4 postgresql9.rb
@@ -7,7 +7,7 @@ class Postgresql9 < Formula
sha1 '240d2d45bc87d8cdad8e2b74cf378f5668b604fe'
depends_on 'readline'
- depends_on 'libxml2' if MacOS.leopard? # Leopard libxml is too old
+ depends_on 'libxml2' if MacOS.version == :leopard
depends_on 'ossp-uuid'
def options
@@ -21,7 +21,7 @@ def options
skip_clean :all
def install
- ENV.libxml2 if MacOS.snow_leopard?
+ ENV.libxml2 if MacOS.version >= :snow_leopard
args = ["--disable-debug",
"--prefix=#{prefix}",
View
2 spidermonkey180.rb
@@ -21,7 +21,7 @@ class Spidermonkey180 < Formula
def install
# aparently this flag causes the build to fail for ivanvc on 10.5 with a
# penryn (core 2 duo) CPU. So lets be cautious here and remove it.
- ENV['CFLAGS'] = ENV['CFLAGS'].gsub(/-msse[^\s]+/, '') if MacOS.leopard?
+ ENV['CFLAGS'] = ENV['CFLAGS'].gsub(/-msse[^\s]+/, '') if MacOS.version == :leopard
# For some reason SpiderMonkey requires Autoconf-2.13
ac213_prefix = Pathname.pwd.join('ac213')
View
8 subversion16.rb
@@ -22,7 +22,7 @@ class Subversion16 < Formula
depends_on 'pkg-config' => :build
# On Snow Leopard, build a new neon. For Leopard, the deps above include this.
- depends_on 'neon' if MacOS.snow_leopard?
+ depends_on 'neon' if MacOS.version >= :snow_leopard
def options
[
@@ -82,7 +82,7 @@ def install
ENV.universal_binary if build_universal?
- if MacOS.leopard?
+ if MacOS.version == :leopard
setup_leopard
else
check_neon_arch if build_universal?
@@ -123,14 +123,14 @@ def install
# Remove hard-coded ppc target, add appropriate ones
if build_universal?
arches = "-arch x86_64 -arch i386"
- elsif MacOS.leopard?
+ elsif MacOS.version == :leopard
arches = "-arch i386"
else
arches = "-arch x86_64"
end
# Use version-appropriate system Perl
- if MacOS.leopard?
+ if MacOS.version == :leopard
perl_version = "5.8.8"
else
perl_version = "5.10.0"

0 comments on commit cb13264

Please sign in to comment.
Something went wrong with that request. Please try again.