Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

gromacs depends on x11

Gromacs depends on libraries from X11. The build breaks when linking to
libSM.dylib if the X11 dependency is not set.

Closes #14935.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
  • Loading branch information...
commit af950891293478d83c6937f00b27db0d319cce09 1 parent fd1d12d
@thomasdunton thomasdunton authored Dennis Luxen committed
Showing with 3 additions and 0 deletions.
  1. +3 −0  Library/Formula/gromacs.rb
View
3  Library/Formula/gromacs.rb
@@ -7,13 +7,16 @@ class Gromacs < Formula
option 'enable-mpi', "Enables MPI support"
option 'enable-double',"Enables double precision"
+ option 'without-x', "Disable the X11 visualizer"
+ depends_on :x11 unless build.include? 'without-x'
depends_on 'fftw'
def install
args = ["--prefix=#{prefix}"]
args << "--enable-mpi" if build.include? 'enable-mpi'
args << "--enable-double" if build.include? 'enable-double'
+ args << "--without-x" if build.include? 'without-x'
system "./configure", *args
system "make"
Please sign in to comment.
Something went wrong with that request. Please try again.