Skip to content
This repository
Browse code

Cairo: Don't build with XCB support on Leopard

The version of XCB included with Leopard is too old to build against.
  • Loading branch information...
commit fef62e271602ba8ae6e84a74a5db6d6d86239866 1 parent 22e095e
Charlie Sharpsteen authored February 16, 2012

Showing 1 changed file with 8 additions and 4 deletions. Show diff stats Hide diff stats

  1. 12  Library/Formula/cairo.rb
12  Library/Formula/cairo.rb
@@ -14,10 +14,14 @@ class Cairo < Formula
14 14
   fails_with_llvm "Throws an 'lto could not merge' error during build.", :build => 2336
15 15
 
16 16
   def install
17  
-    system "./configure", "--disable-dependency-tracking",
18  
-                          "--prefix=#{prefix}",
19  
-                          "--with-x",
20  
-                          "--enable-xcb"
  17
+    args = %W[
  18
+      --disable-dependency-tracking
  19
+      --prefix=#{prefix}
  20
+      --with-x
  21
+    ]
  22
+    args << '--enable-xcb' unless MacOS.leopard?
  23
+
  24
+    system "./configure", *args
21 25
     system "make install"
22 26
   end
23 27
 end

0 notes on commit fef62e2

Please sign in to comment.
Something went wrong with that request. Please try again.