Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Ruby should have gdbm as a dependency #11735

Closed
frangio opened this Issue · 2 comments

2 participants

@frangio

The dbm library which is part of Ruby stdlib is not installed if it doesn't find a dbm implementation (such as gdbm) on the computer.

I was unable to require 'yaml/dbm' on my Homebrew Ruby installation, so I uninstalled it, installed gdbm, and reinstalled Ruby, and the problem was fixed.

See this related issue by the developer of the Psych YAML engine (although on a different project).

@adamv
Owner

We do this for Python, seems reasonable.

@adamv adamv was assigned
@adamv
Owner

Fixed in bf3dfa9 - thanks for the suggestion.

@adamv adamv closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.