Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Wireshark 1.8.3 missing gnutls due to libgnutls-config deprecation #16257

Closed
bertjwregeer opened this Issue · 7 comments

4 participants

@bertjwregeer

There is an issue with the Wireshark formula in that gnutls deprecated libgnutls-config, and at this point Wireshark's configure won't pick it up even if installed.

A patch against the configure script to use pkg-config gnutls instead would solve the problem.

Making a note here, if I get a chance I'll work on such a patch.

@bertjwregeer

I cried wolf too early (did some searching based simply on what I saw from configure, but not by reading config.log), here is the actual issue:

configure:16597: checking for LIBGNUTLS
configure:16604: $PKG_CONFIG --exists --print-errors "gnutls >= 1.2.0 gnutls < 3"
Requested 'gnutls < 3' but version of GnuTLS is 3.1.4
You may find new versions of GnuTLS at http://www.gnu.org/software/gnutls/
configure:16607: $? = 1
configure:16621: $PKG_CONFIG --exists --print-errors "gnutls >= 1.2.0 gnutls < 3"
Requested 'gnutls < 3' but version of GnuTLS is 3.1.4
You may find new versions of GnuTLS at http://www.gnu.org/software/gnutls/
configure:16624: $? = 1
configure:16638: result: no
Requested 'gnutls < 3' but version of GnuTLS is 3.1.4
You may find new versions of GnuTLS at http://www.gnu.org/software/gnutls/

So it seems that Wireshark will not build with a newer version of GnuTLS...

@bertjwregeer

In Gentoo they have a patch to configure.in that changes the version requirements so that it can be built against GnuTLS 3=<...

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-analyzer/wireshark/files/wireshark-1.8.3-gnutls3.patch?annotate=1.1

Will try to integrate this within homebrew's formula later tonight and see if it works.

@bertjwregeer

One last update, seems it is a licensing issue:

https://bugzilla.novell.com/show_bug.cgi?id=775737

Would we be okay with providing a patch that does allow it to build? Or should I work on a Keg-only GnuTLS version.

@mikemcquaid
Owner

If it's a licensing issue then we shouldn't build it with that option. Other maintainers may disagree.

@pvaneynd

In Debian wireshark depends on gnutls26 aka the GPL2 2.12.20 version. I created a keg-only gnutls26 based on 2.12.21 and then modified the PKG_CONFIG_PATH to point to that version before the rest of homebrew.

The result is that wireshark finds gnutls 2.12.20 and builds with SSL support again.

Could we move forward in this way?

@adamv
Owner

Pull request, anyone?

@bertjwregeer

@pvaneynd If you already have this built out and working, let's go with it. If you feel your solution is suboptimal let me know and I will take a look.

I was thinking of doing something like what was done for the monotone brew file, it contains it's own copy of an older version of Botan which is installed in libexec so it is not even keg-only.

@adamv adamv closed this in 444cc44
@norioxkimura norioxkimura referenced this issue from a commit in norioxkimura/homebrew
@adamv adamv Wireshark: link against GnuTLS 2
Closes #16257.
f11888d
@cooljeanius cooljeanius referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@rajeeja rajeeja referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.