Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

curl-ca-bundle failed to build on OSX10.8.2 #17286

Closed
MattRogish opened this Issue · 16 comments

7 participants

@adamv
Owner

Please post your brew --config for reference, thanks.

@MattRogish

Hi Adam,

Thanks! As requested:

brew --config
HOMEBREW_VERSION: 0.9.3
ORIGIN: https://github.com/mxcl/homebrew.git
HEAD: f8e58e1
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
CPU: quad-core 64-bit ivybridge
OS X: 10.8.2-x86_64
Xcode: 4.5.2
CLT: 4.5.0.0.1.1249367152
LLVM-GCC: build 2336
Clang: 4.1 build 421
X11: N/A
System Ruby: 1.8.7-358
Perl: /usr/bin/perl
Python: /usr/bin/python
Ruby: /Users/rogish/.rvm/rubies/ruby-1.9.3-p327/bin/ruby

@adamv
Owner

I get the same error on Snow Leopard.

@mistydemeo
Owner

Hm, works for me on Lion.

I ship a pre-generated copy of the certs in tigerbrew, since Tiger is missing one of the perl modules required by the script. Maybe we should do that in homebrew too.

@chinthakagodawita

Same issue here on 10.8.2 (https://gist.github.com/4680112). brew --config is below:

HOMEBREW_VERSION: 0.9.4
ORIGIN: https://github.com/mxcl/homebrew.git
HEAD: f2a1bc1627efa8929052f847b2221ccc1414e156
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
CPU: quad-core 64-bit arrandale
OS X: 10.8.2-x86_64
Xcode: 4.5
CLT: 4.5.0.0.1.1249367152
LLVM-GCC: build 2336
Clang: 4.1 build 421
X11: 2.7.2 => /opt/X11
System Ruby: 1.8.7-358
Perl: /usr/bin/perl
Python: /usr/bin/python
Ruby: /Users/torpy/.rvm/rubies/ruby-1.9.3-p362/bin/ruby
@adamv
Owner

Is there a Perl module this should be asking for?

@derekslenk

I am getting the same issue. Anyone figure it out?

➜ cgminer git:(master) brew --config
HOMEBREW_VERSION: 0.9.4
ORIGIN: https://github.com/mxcl/homebrew.git
HEAD: 4433790
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
CPU: 8-core 64-bit sandybridge
OS X: 10.8.2-x86_64
Xcode: 4.6
CLT: 4.6.0.0.1.1358221012
LLVM-GCC: build 2336
Clang: 4.2 build 425
X11: N/A
System Ruby: 1.8.7-358
Perl: /usr/bin/perl
Python: /usr/bin/python
Ruby: /usr/bin/ruby => /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby

@pjkirner

Same

$ brew --config
HOMEBREW_VERSION: 0.9.4
ORIGIN: https://github.com/mxcl/homebrew
HEAD: a95b657
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
CPU: dual-core 64-bit penryn
OS X: 10.8.2-x86_64
Xcode: 4.6
CLT: 4.6.0.0.1.1358221012
LLVM-GCC: build 2336
Clang: 4.2 build 425
X11: N/A
System Ruby: 1.8.7-358
Perl: /usr/bin/perl
Python: /usr/bin/python
Ruby: /usr/bin/ruby => /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby

@jacknagel
Owner

This works fine for me on 10.6, but I can reproduce the error if I stick gibberish in $url in the perl script.

@jacknagel
Owner

Can someone that this fails for please do:

$ /usr/bin/env perl -e 'use Getopt::Std'; echo $?
0
$ /usr/bin/env perl -e 'use MIME::Base64'; echo $?
0
$ /usr/bin/env perl -e 'use LWP::UserAgent'; echo $?
0
@adamv
Owner
$ /usr/bin/env perl -e 'use Getopt::Std'; echo $?
0
$ /usr/bin/env perl -e 'use MIME::Base64'; echo $?
0
$ /usr/bin/env perl -e 'use LWP::UserAgent'; echo $?
0

Will try at home too.

@chinthakagodawita

Yep, get the same output here too:

$ /usr/bin/env perl -e 'use Getopt::Std'; echo $?
0
$ /usr/bin/env perl -e 'use MIME::Base64'; echo $?
0
$ /usr/bin/env perl -e 'use LWP::UserAgent'; echo $?
0
@jacknagel
Owner

I'm going to bundle this up and stick it on the sourceforge account.

@jacknagel
Owner

I copied the file into the main Homebrew account

@jacknagel jacknagel closed this issue from a commit
@jacknagel jacknagel curl-ca-bundle: use prebuilt bundle
The mk-ca-bundle script uses perl modules that don't work consistently
across proxies, etc. so just package it up.

Fixes #17286.
e8e7cbf
@jacknagel jacknagel closed this in e8e7cbf
@fgeller fgeller referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@n1k0 n1k0 referenced this issue from a commit
@jacknagel jacknagel curl-ca-bundle: use prebuilt bundle
The mk-ca-bundle script uses perl modules that don't work consistently
across proxies, etc. so just package it up.

Fixes #17286.
e322559
@cooljeanius cooljeanius referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@erbmicha erbmicha referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@phatblat phatblat referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@rajeeja rajeeja referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.