Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Weechat failed to build on 10.8.3 #18499

Closed
danieljaouen opened this Issue · 7 comments

4 participants

@adamv
Owner

What Python do you have?

$ ls -la /usr/lib/libpython2.7.dylib
lrwxr-xr-x  1 root  wheel  68 Mar 26  2012 /usr/lib/libpython2.7.dylib -> ../../System/Library/Frameworks/Python.framework/Versions/2.7/Python
$ file /usr/lib/libpython2.7.dylib
/usr/lib/libpython2.7.dylib: Mach-O universal binary with 2 architectures
/usr/lib/libpython2.7.dylib (for architecture x86_64):  Mach-O 64-bit dynamically linked shared library x86_64
/usr/lib/libpython2.7.dylib (for architecture i386):    Mach-O dynamically linked shared library i386
@danieljaouen

The system Python, as well as a homebrew-installed Python (which is the default Python on my PATH):

daniel at Daniels-MacBook-Pro-2 in ~/src
○ which python
/usr/local/bin/python

daniel at Daniels-MacBook-Pro-2 in ~/src
○ python -V
Python 2.7.3
@danieljaouen
daniel at Daniels-MacBook-Pro-2 in ~
○ find /usr/local -name 'libpython2.7*'
/usr/local/Cellar/python/2.7.3/Frameworks/Python.framework/Versions/2.7/lib/libpython2.7.dylib
/usr/local/Cellar/python/2.7.3/Frameworks/Python.framework/Versions/2.7/lib/python2.7/config/libpython2.7.a
/usr/local/Cellar/python/2.7.3/Frameworks/Python.framework/Versions/2.7/lib/python2.7/config/libpython2.7.dylib

daniel at Daniels-MacBook-Pro-2 in ~
○ file /usr/local/Cellar/python/2.7.3/Frameworks/Python.framework/Versions/2.7/lib/libpython2.7.dylib
/usr/local/Cellar/python/2.7.3/Frameworks/Python.framework/Versions/2.7/lib/libpython2.7.dylib: Mach-O 64-bit dynamically linked shared library x86_64
@locojay

same issue here

which python                                                                                                                                                                                                             ⏎
/usr/local/bin/python

python -V
Python 2.7.3

unlinking brew python and using system python results in the same error

@lasko

After seeing this I decided I would chime in real quick.

I'm currently on 10.8.3

HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
CPU: 8-core 64-bit ivybridge
OS X: 10.8.3-x86_64
Xcode: 4.6.1
CLT: 4.6.0.0.1.1358221012
LLVM-GCC: build 2336
Clang: 4.2 build 425
X11: 2.7.4 => /opt/X11
System Ruby: 1.8.7-358
Perl: /usr/bin/perl
Python: /usr/local/bin/python => /usr/local/Cellar/python/2.7.3/Frameworks/Python.framework/Versions/2.7/bin/python2.7
Ruby: /usr/bin/ruby => /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby

And weechat built with:
HOMEBREW_MAKE_JOBS=1 VERBOSE=1 brew install --aspell --guile --lua --perl --python --ruby weechat

and everything appears functional and

$ weechat-curses --version
0.4.0

$ weechat-curses
1.weechatxWeeChat 0.4.0 (C) 2003-2013 - http://www.weechat.org/
x10:11:14 | ___ __ ______________ _____
x10:11:14 | __ | / /___________ ____/__ /_______ __ /_
x10:11:14 | __ | /| / /_ _ \ _ \ / __ __ \ __ `/ /
x10:11:14 | __ |/ |/ / / / __/ /_ _ / / / // // /
x10:11:14 | __
/|/ ___/_/____/ // //__,/ _/
x10:11:14 | WeeChat 0.4.0 [compiled on Mar 23 2013 10:08:40]
x10:11:14 | - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
x10:11:15 | perl scripts loaded: buffers, iset
x10:11:15 =!= | python: warning, license "MIT" for script "notification_center" differs from plugin license ("GPL3")
x10:11:15 | python scripts loaded: notification_center
x10:11:15 | script: downloading list of scripts...
x10:11:15 | Plugins loaded: alias, aspell, fifo, guile, irc, logger, lua, perl, python, relay, rmodifier, ruby, script, tcl, xfer
x10:11:17 | script: 238 scripts for WeeChat 0.4.0

I would also like to note that this is a fairly recently fresh install of Mac OSX 10.8.3 (<1 week) so little to no modifications to the system have been made.

@danieljaouen

I'm still seeing this issue. It probably has something to do with the fact that I have an additional Python 2.7 installed via homebrew.

The weird thing is, I can download the source directly ( http://www.weechat.org/download/ ), and everything links and compiles just fine.

@adamv
Owner

We updated to Weechat 0.4.1 with a Python fix. I'd recommend trying the install and opening new issues.

@adamv adamv closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.