Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Error installing riak 0.14.1 #5820

Closed
yudixue opened this Issue · 5 comments

5 participants

@yudixue

Failed to install riak 0.14.1 with all dependency pre-installed

console log

@Sharpie
Collaborator

Riak 0.14.1 can't compile against the last two versions of Erlang. See issue #4723 for discussion and work-arounds.

@adamv
Owner

Do brew update then do:

brew install erlang

to get Erlang R14B03 and then

brew install --HEAD --ignore-dependencies riak -v

to install the HEAD riak (and NOT also install HEAD Erlang.)

(Leaving this issue open as this will come up again if I close it.)

@j2labs

I just had success compiling Riak 0.14.2 with this approach.

@timuruski

Worked fine for me too.

@adamv
Owner

Riak 1.0.0 will be merged soon: #7921

@adamv adamv closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.