Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Add X11 dependency to gromacs. #14935

Closed
wants to merge 1 commit into from

2 participants

@thomasdunton

Gromacs depends on libraries from X11. The build breaks when linking to
libSM.dylib if the X11 dependency is not set.

@thomasdunton thomasdunton Add X11 dependency to gromacs.
Gromacs depends on libraries from X11. The build breaks when linking to
libSM.dylib if the X11 dependency is not set.
b45865d
@adamv
Owner

Does it need the full X11 dependency or only some of the libs?

@thomasdunton

It requires full X11 for the built in visualization functionality. There is a build option --without-x, which would remove the dependency on X11 by not building the visualizer, but that's usually only something you would do for clusters.

@adamv adamv closed this pull request from a commit
@thomasdunton thomasdunton gromacs depends on x11
Gromacs depends on libraries from X11. The build breaks when linking to
libSM.dylib if the X11 dependency is not set.

Closes #14935.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
f203333
@adamv adamv closed this in f203333
@halloleo halloleo referenced this pull request from a commit
@thomasdunton thomasdunton gromacs depends on x11
Gromacs depends on libraries from X11. The build breaks when linking to
libSM.dylib if the X11 dependency is not set.

Closes #14935.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
4147278
@DennisOSRM DennisOSRM referenced this pull request from a commit
@thomasdunton thomasdunton gromacs depends on x11
Gromacs depends on libraries from X11. The build breaks when linking to
libSM.dylib if the X11 dependency is not set.

Closes #14935.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
af95089
@snakeyroc3 snakeyroc3 referenced this pull request from a commit in snakeyroc3/homebrew
@thomasdunton thomasdunton gromacs depends on x11
Gromacs depends on libraries from X11. The build breaks when linking to
libSM.dylib if the X11 dependency is not set.

Closes #14935.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
9a23269
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Sep 14, 2012
  1. @thomasdunton

    Add X11 dependency to gromacs.

    thomasdunton authored
    Gromacs depends on libraries from X11. The build breaks when linking to
    libSM.dylib if the X11 dependency is not set.
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 0 deletions.
  1. +1 −0  Library/Formula/gromacs.rb
View
1  Library/Formula/gromacs.rb
@@ -8,6 +8,7 @@ class Gromacs < Formula
option 'enable-mpi', "Enables MPI support"
option 'enable-double',"Enables double precision"
+ depends_on :x11
depends_on 'fftw'
def install
Something went wrong with that request. Please try again.