Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

lv2 audio tools #16232

Closed
wants to merge 6 commits into from

2 participants

@benswift

Lv2 libs and plugins by David Robillard for working with Lv2 audio.

http://lv2plug.in
http://drobilla.net

@adamv
Owner

Maintainers: any reason this hasn't been pulled yet?

@adamv adamv was assigned
@benswift

There was some discussion on the IRC channel (can't remember the person I spoke to, sorry) about the fact that there were several formulas in the same pull request, even though only lilv has an explicit dependency.

The reason for this is that they all depend (at run-time) on 'lv2', but because of the way that Dave has designed the rest of the tools ('unixy' do one thing well) the rest of them work together to provide various functions.

So it wouldn't work to have mda-lv2 (a set of audio plugins/ugens) without lv2, for instance. I realise that means that it's seven formulas in one pull request, and that does clutter things up a bit, but hopefully it's clear why I did it that way. If there's a better way, though, I'm open to suggestions.

@adamv
Owner

It's true, we prefer separate pull requests for separate formulae, even if they are all going to be let in anyway.
It makes it easier to make individual fixes to them.

But I don't want to force that here if these are all ready to go.

@adamv
Owner
==> Installing lilv dependency: sratom
==> Downloading http://download.drobilla.net/sratom-0.4.0.tar.bz2
/usr/bin/curl -f#LA Homebrew 0.9.3 (Ruby 1.8.7-358; Mac OS X 10.7.5) http://download.drobilla.net/sratom-0.4.0.tar.bz2 -o /usr/local/homebrew-cache/sratom-0.4.0.tar.bz2
######################################################################## 100.0%
/usr/bin/tar xf /usr/local/homebrew-cache/sratom-0.4.0.tar.bz2
==> ./waf configure --prefix=/usr/local/homebrew/Cellar/sratom/0.4.0
./waf configure --prefix=/usr/local/homebrew/Cellar/sratom/0.4.0 
Setting top to                           : /private/tmp/sratom-pXrf/sratom-0.4.0 
Setting out to                           : /private/tmp/sratom-pXrf/sratom-0.4.0/build 
Checking for 'gcc' (c compiler)          : cc 

Global Configuration 
 * Install prefix                        : /usr/local/homebrew/Cellar/sratom/0.4.0 
 * Debuggable build                      : False 
 * Build documentation                   : False 

Sratom Configuration 
Checking for program pkg-config          : /usr/local/opt/pkg-config/bin/pkg-config 
Checking for 'lv2' >= 1.0.0              : not found 
The configuration failed
(complete log in /private/tmp/sratom-pXrf/sratom-0.4.0/build/config.log)
==> Configuration
HOMEBREW_VERSION: 0.9.3
HEAD: a239543568e0a93a9fead7dd11ee7be113e4b740
HOMEBREW_CELLAR: /usr/local/homebrew/Cellar
CPU: quad-core 64-bit sandybridge
OS X: 10.7.5-x86_64
Xcode: 4.5.2
CLT: 4.5.0.0.1.1249367152
X11: 2.6.4 => /usr/X11
==> ENV
CC: cc
CXX: c++
MAKEFLAGS: -j4
CMAKE_PREFIX_PATH: /usr/local
CMAKE_INCLUDE_PATH: /usr/include/libxml2:/System/Library/Frameworks/OpenGL.framework/Versions/Current/Headers/
CMAKE_LIBRARY_PATH: /System/Library/Frameworks/OpenGL.framework/Versions/Current/Libraries
PKG_CONFIG_PATH: /usr/local/lib/pkgconfig
ACLOCAL_PATH: /usr/local/share/aclocal
OBJC: cc
PATH: /usr/local/homebrew/Library/ENV/4.3:/usr/local/opt/pkg-config/bin:/usr/bin:/bin:/usr/sbin:/sbin

Missing dep?

@adamv
Owner

Please ensure that all formulae have the proper deps declared.

@benswift

Ok, sorry about that. I've fixed the deps problems (both compile-time and run-time with otool) and have re-done the patches as one-branch-per-formula (under benswift/homebrew). Would you prefer if I closed this request and submitted these other branches individually?

Happy to do whatever works best for you guys, and thanks for your patience while I get the hang of things.

@adamv
Owner

If the is still one formula per commit, and this pull request was made from a non-master branch, then I'm OK with you git push -f-ing it here and I'll take a look when I get a chance.

@benswift

Ok, done. Cheers.

@adamv
Owner

Made one comment, looks applicable to most of the formulae.

@benswift

Yep, fixed those problems.

@adamv
Owner

Need commas between the arguments

@benswift

Added commas, it all works on my end. Sorry about that.

@adamv adamv closed this pull request from a commit
@benswift benswift mda-lv2 1.0.0
http://drobilla.net/software/mda-lv2/

Closes #16232.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
ddd88b5
@adamv adamv closed this in ddd88b5
@norioxkimura norioxkimura referenced this pull request from a commit in norioxkimura/homebrew
@benswift benswift mda-lv2 1.0.0
http://drobilla.net/software/mda-lv2/

Closes #16232.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
48d9aab
@guyzmo guyzmo referenced this pull request from a commit
Commit has since been removed from the repository and is no longer available.
@guyzmo guyzmo referenced this pull request from a commit
Commit has since been removed from the repository and is no longer available.
@cooljeanius cooljeanius referenced this pull request from a commit
Commit has since been removed from the repository and is no longer available.
@rajeeja rajeeja referenced this pull request from a commit
Commit has since been removed from the repository and is no longer available.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
View
19 Library/Formula/lilv.rb
@@ -0,0 +1,19 @@
+require 'formula'
+
+class Lilv < Formula
+ homepage 'http://drobilla.net/software/lilv/'
+ url 'http://download.drobilla.net/lilv-0.14.4.tar.bz2'
+ sha1 '1f04d7363038ba09e794dc5ab510e70423762426'
+
+ depends_on 'pkg-config' => :build
+ depends_on 'lv2'
+ depends_on 'serd'
+ depends_on 'sord'
+ depends_on 'sratom'
+
+ def install
+ system "./waf", "configure", "--prefix=#{prefix}"
+ system "./waf"
+ system "./waf", "install"
+ end
+end
View
13 Library/Formula/lv2.rb
@@ -0,0 +1,13 @@
+require 'formula'
+
+class Lv2 < Formula
+ homepage 'http://lv2plug.in'
+ url 'http://lv2plug.in/spec/lv2-1.2.0.tar.bz2'
+ sha1 '5affb79b357c8f8d7f77cceb7252392845d3e072'
+
+ def install
+ system "./waf", "configure", "--prefix=#{prefix}", "--lv2dir=#{share}/lv2"
+ system "./waf", "build"
+ system "./waf", "install"
+ end
+end
View
16 Library/Formula/mda-lv2.rb
@@ -0,0 +1,16 @@
+require 'formula'
+
+class MdaLv2 < Formula
+ homepage 'http://drobilla.net/software/mda-lv2/'
+ url 'http://download.drobilla.net/mda-lv2-1.0.0.tar.bz2'
+ sha1 '03ad1115405bbc870b3cd10f557f326b38cbb74d'
+
+ depends_on 'pkg-config' => :build
+ depends_on 'lv2'
+
+ def install
+ system "./waf", "configure", "--prefix=#{prefix}", "--lv2dir=#{share}/lv2"
+ system "./waf"
+ system "./waf", "install"
+ end
+end
View
15 Library/Formula/serd.rb
@@ -0,0 +1,15 @@
+require 'formula'
+
+class Serd < Formula
+ homepage 'http://drobilla.net/software/serd/'
+ url 'http://download.drobilla.net/serd-0.18.2.tar.bz2'
+ sha1 '9472be8d6f407affca5c8fa3125a5fbe49af967e'
+
+ depends_on 'pkg-config' => :build
+
+ def install
+ system "./waf", "configure", "--prefix=#{prefix}"
+ system "./waf"
+ system "./waf", "install"
+ end
+end
View
16 Library/Formula/sord.rb
@@ -0,0 +1,16 @@
+require 'formula'
+
+class Sord < Formula
+ homepage 'http://drobilla.net/software/sord/'
+ url 'http://download.drobilla.net/sord-0.10.4.tar.bz2'
+ sha1 '7ac6b593bf391b5670fec178ed7bf81b081094b5'
+
+ depends_on 'pkg-config' => :build
+ depends_on 'serd'
+
+ def install
+ system "./waf", "configure", "--prefix=#{prefix}"
+ system "./waf"
+ system "./waf", "install"
+ end
+end
View
19 Library/Formula/sratom.rb
@@ -0,0 +1,19 @@
+require 'formula'
+
+class Sratom < Formula
+ homepage 'http://drobilla.net/software/sratom/'
+ url 'http://download.drobilla.net/sratom-0.4.0.tar.bz2'
+ sha1 '898ef54df92785a2cfe2787ff2002e0b713044fd'
+
+ depends_on 'pkg-config' => :build
+ depends_on 'lv2'
+ depends_on 'serd'
+ depends_on 'sord'
+
+ def install
+ system "./waf", "configure", "--prefix=#{prefix}"
+ system "./waf"
+ system "./waf", "install"
+ end
+
+end
Something went wrong with that request. Please try again.