This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

s3-backer: openssl fix

Adds an OpenSSL dependency to override using the depreciated system
version.

Closes #34134.

Signed-off-by: Mike McQuaid <mike@mikemcquaid.com>
  • Loading branch information...
DomT4 authored and MikeMcQuaid committed Nov 12, 2014
1 parent f16e625 commit 6b9d60d474d72b1848304297d91adc6120ea6f96
Showing with 12 additions and 6 deletions.
  1. +12 −6 Library/Formula/s3-backer.rb
@@ -1,16 +1,22 @@
require 'formula'
require "formula"
class S3Backer < Formula
homepage 'http://code.google.com/p/s3backer/'
url 'https://s3backer.googlecode.com/files/s3backer-1.3.7.tar.gz'
sha1 'c75c7e70cb38bcac41d342a2bdb63e9505ab550a'
homepage "https://code.google.com/p/s3backer/"
url "https://s3backer.googlecode.com/files/s3backer-1.3.7.tar.gz"
sha1 "c75c7e70cb38bcac41d342a2bdb63e9505ab550a"
revision 1
depends_on 'pkg-config' => :build
depends_on "pkg-config" => :build
depends_on "openssl"
depends_on :osxfuse
def install
inreplace "configure", "-lfuse", "-losxfuse"
system "./configure", "--prefix=#{prefix}"
system "make install"
system "make", "install"
end
test do
system "#{bin}/s3backer", "--version"
end
end

0 comments on commit 6b9d60d

Please sign in to comment.