Postgres install error on Lion #10157

Closed
rimian opened this Issue Feb 14, 2012 · 2 comments

Projects

None yet

2 participants

@rimian
rimian commented Feb 14, 2012

Hi,

I can no longer get brew to install postgres. It was working fine a week or so ago but my postgres install mysteriously stopped working.

It fails here:

Error: Failed executing: ./configure --disable-debug --prefix=/usr/local/Cellar/postgresql/9.1.2 --datadir=/usr/local/Cellar/postgresql/9.1.2/share/postgresql --docdir=/usr/local/Cellar/postgresql/9.1.2/share/doc/postgresql --enable-thread-safety --with-bonjour --with-gssapi --with-krb5 --with-openssl --with-libxml --with-libxslt --with-ossp-uuid --with-python --with-perl ARCHFLAGS='-arch\ x86_64'

Log:
https://gist.github.com/1821908

Install Output:
https://gist.github.com/1821976

Brew doctor:
/usr/local/bin/brew:74: warning: Insecure world writable dir /usr/local/Library in PATH, mode 040777
/usr/local/Library/Homebrew/global.rb:43: warning: Insecure world writable dir /usr/local/Library in PATH, mode 040777
/usr/local/bin/brew:74: warning: Insecure world writable dir /usr/local/Library in PATH, mode 040777
Your system is raring to brew.

:)

@jacknagel
Contributor

brew unlink ossp-uuid && brew link ossp-uuid

@rimian
rimian commented Feb 14, 2012

That worked!

I am impressed by the speed of your response. Much appreciated. Thanks!

@jacknagel jacknagel closed this Feb 14, 2012
@xu-cheng xu-cheng locked and limited conversation to collaborators Feb 16, 2016
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.